Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Unable to download MP3s with "save as" while using FF 38.0.1

  • 16 Antworten
  • 12 haben dieses Problem
  • 133 Aufrufe
  • Letzte Antwort von jscher2000

more options

I run FF 38.0.1 on Win7. I download MP3 files from our audiobook forum by right clicking on the link and selecting "save as". Since moving to FF38, using "save as" method to download a file gives me only a file fragment. I am able to use "save as" to download the complete MP3 file with IE or Chrome.

For an example of the files I am trying to download, see "Listen" links under "Listen URL" here: https://forum.librivox.org/viewtopic.php?f=12&t=56485 (This is a sample project file - we have a couple hundred of these projects open at any point in time, where we collect the MP3s until it is time to put them in finished audiobook form. The issue seems to arise across the board on all of the MP3 files on our open projects.)

We have quite a few FF users among our audiobook community - and several people have now reported this problem when they updated their FF to FF38. This was not an issue with earlier versions of FF. None of the other reports indicate what OS is being used. We download both MP3 and FLAC files, and the people with this problem have it with all files that they try to download using FF (so it's not that some MP3s can be saved and others can't - the "save as" function doesn't work for any of them). They also report no issues using Save As to download any files using IE or Chrome.

One of our forum users reported that if you begin playing the MP3 file by opening the link to the MP3 in a new tab, you can then navigate to the new tab, right click anywhere in the page and click "save page as" to successfully download the MP3 file. I have tried this and it does work. But it would be quicker to be able to use "save as" without having to begin playing the audio file first in a new tab.

I have tried using "save as" to download an MP3 file for one of our finished projects which are hosted over at Internet Archive. That works fine, and "save as" results in the entire MP3 file being downloaded. As an example, I successfully downloaded the MP3 of chapter 1 here: https://archive.org/download/drjekyllandmrhydedr_1505_librivox

Thanks for your help in checking this out!

Alle Antworten (16)

more options

I went to your web link, and did a download only using Save As. No problem.

Please describe in detail what you are doing, and what Firefox does.

Update your Flash Player Version

See if there are updates for your graphics drivers https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?

more options

Yes, you can download using save as. Only a fraction of the file is downloaded, however. Did you actually try to play the file you downloaded? The first file on that page should have 4MB, what you download this way is a mere 354 Bytes.

This problem was never there before, it only occurred with the latest version of firefox. I'm very loathe to switch to another browser, and it is irksome to do roundabouts to avoid this problem, so any solution would be much appreciated by the large librivox community. :)

more options

Further information from a user:

I've updated my Flash Player to Version, I tried with Firefox in Safe Mode, but the issue remains.

The issue seems to be with the https links. The uploads folder has the links in http form so they work, and also if you open the https link in another tab it redirects to the http link so then it works, too.

ETA: One difference I see when trying to "Save Link As..." from the forum is that the "Save As" window has the "Firefox HTML document" selected, which means it doesn't recognise it as an audio file, while if I use the "Save Link As..." from the uploads folder, the "Save As" window has the "BSplayer file" selected, BSplayer being my media player software, which means then it does recognise it as an audio file.

My OS for these tries is Windows XP, Firefox 38.0.1

And I just tried with a relative's laptop, in Windows 8.1, Firefox 38.0.1. Same issue.

more options

Fred, It is as belana says - only a fragment of the file downloads using "save as". I will update my flash player and try opening ff in safe mode to see if I have anything to add to ta_mosquito's comments. mas

more options

Have you tried Firefox in Safe mode?

Deleting the mimeTypes.rdf will reset all download actions to the default settings.


more options

Opps  :-(

Deleting the mimeTypes.rdf will reset all download actions to the default settings.

Type about:support in the address bar and press enter.

Under the page logo on the left side you will see Application Basics. Under this find Profile Folder. To it’s right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Locate the mimeTypes file. Then rename or delete it. Restart Firefox.

more options

Thanks for your help Fred.

I have updated my flash player using the link you provided (thanks for making it so easy).

I used your link to check for windows updates and installed all that it found. I then restarted my computer.

I opened firefox in safe mode (with add-ins disabled), and then found the mimeTypes file in the Profile folder.

I closed Firefox and renamed the mimeTypes file.

I restarted Firefox and tried to download chapter 12 from this webpage by right clicking on the link and selecting "save as": https://forum.librivox.org/viewtopic.php?f=12&t=56120

The downloaded file was 357 bytes. I know from downloading the file earlier today using Chrome that it should be 17,048 KB. So still some issue with the download from a link using "save as".

: (


more options

My last suggestion is that you disable the security programs and try again. I've called the big guys to help you. Good luck.

more options

Fred, Sorry, I'm not very technical. I don't know what you mean by "disable the security programs." Do you mean my "McAfee Total Protection" software? Thank you for all your efforts to figure this out. MaryAnn

more options

Yes. Some protection programs cause problems for Firefox. Once this is confirmed, a solution can be found.

more options

I have now upgraded to FF 38.0.5 and the issue still remains.

I also have the problem on both my home and work computers - home I use McAffee, work uses Sophis anti-virus. For that reason, I don't believe that the issue is tied to my security program.

more options

I see a HTTP/1.0 301 Moved Permanently response if you check this in the Web Console (Firefox/Tools > Web Developer)

You can also see that response if you open the 354 byte file in a text editor.

<h1>Moved Permanently</h1>
<p>The document has moved <a href="http://uploads.librivox.org/maryannspiegel/uptrail_01_grey_128kb.mp3">here</a>.</p>

To save the file you would have to use the moved location URL.

more options

mas595 said

I also have the problem on both my home and work computers - home I use McAffee, work uses Sophis anti-virus.

Many employers place blocks on work computers.

As a test, disable all security programs on your home computer, then try to do a download.

Do you have problems downloading from other sites, or just the one?

more options


Thank you again for your help.

I turned off the McAfee on my home computer and tried to download an MP3 file from the Librivox site (one that I had uploaded, so I knew it was safe, at least as of yesterday :) ), but I had the same problem - what downloaded was 363 bytes rather than the 6,763 KB that I should have gotten.

I have never had reason to (and so never tried to) download MP3 files from sites other than forum.librivox.org.

I did not have this problem on either my work or home computers until Firefox updated to 38.0.1. A number of people working on the Librivox project have reported the problem and when we ask them what browser they are using, all have said FF 38. A number of other people have reported that they are using FF with no problem downloading files, but those people have each indicated that they are running an older (earlier than FF38) version of FF.

I appreciate your help trying to solve this. At the suggestion of another Librivox volunteer, I have installed the "Downthemall" Add-on to FF. Using that add-on, I am now able to download complete files from the working forum pages at Librivox.

So, the problem is not really solved, but I have found a work-around that allows me to download the MP3 files I need without using to another browser or having to open the MP3 file in a new tab first.

more options

Well, let's start with the issue of an HTTPS URL redirecting to an HTTP URL. This generates a mixed active content warning as you can see in the first screen shot attached (clicking the link to follow it).

After allowing the insecure content, I can play the video and save it using the right-click context menu > Save Audio As.

However, even after allowing the insecure content, if I right-click > Save Link As on the Listen link I get a copy of that intermediate page instead of the actual audio data. If you rename the extension of the small file from .mp3 to .html and open it in a tab, you will see what I mean.

So in my test, after allowing the insecure content, Firefox follows the redirect in the case of interactive listening, and does not follow in the case of Save Link As.

This didn't happen in Firefox 37? Perhaps it's a new feature for Save Link As, or perhaps audio was not previously treated as active content so it's a previously unnoticed behavior of Save Link As.

more options

If I don't disable protection against insecure content, and I click the Listen link (sometimes I need to click twice), then I can download the whole track by using right-click > Save Link As on the redirect notification page, since that link is to the actual media. (See attached screen shot.)

Actually, that is what cor-el was pointing out in the last line of this post: https://support.mozilla.org/questions/1064053#answer-735903

Geändert am von jscher2000