Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Telefonnummer anzurufen, eine SMS an eine Telefonnummer zu senden oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

In Firefox 36 with settings in tab (browser.preferences.inContent=true) changes in proxy settings do not get stored.

  • 7 Antworten
  • 1 hat dieses Problem
  • 19 Aufrufe
  • Letzte Antwort von FredMcD

more options

Firefox 36.0.1 set to settings in tab (browser.preferences.inContent=true) opens the new settings tab instead of the classic settings popup menu. Here in section network settings a classic windows pops up as in older versions. Chanching those proxy settings do not get stored on «OK». Clicking «OK» has the same effect as clicking «Quit». With (browser.preferences.inContent=false) and settings in classic popup menus changing proxy settings still works.

Did I miss an other setting to change beside (browser.preferences.inContent=true) to get settings in tab to work?

Firefox 36.0.1 set to settings in tab (browser.preferences.inContent=true) opens the new settings tab instead of the classic settings popup menu. Here in section network settings a classic windows pops up as in older versions. Chanching those proxy settings do not get stored on «OK». Clicking «OK» has the same effect as clicking «Quit». With (browser.preferences.inContent=false) and settings in classic popup menus changing proxy settings still works. Did I miss an other setting to change beside (browser.preferences.inContent=true) to get settings in tab to work?

Ausgewählte Lösung

With FF38.0 and «settings in tab» activatet per default, the mentioned problem with not safed proxi settings is not there anymore.

So it seems to be solved.

Diese Antwort im Kontext lesen 👍 0

Alle Antworten (7)

more options

I'm not seeing any problems with making changes to the connection settings. If I open about:preferences in one window and have the about:config page in another window then I see the network.proxy prefs change after closing the connection settings page.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

If you do not keep changes after a restart or otherwise have problems with preferences, see:

more options

I did just try your suggestion. I started FF36.0.1 in safe mode without any add-ons.

Unforunately, it is still the same. With (browser.preferences.inContent=true), changes in proxy settings do not get stored. With (browser.preferences.inContent=false), proxy changes get stored.

My FF ist the German version and it runs on Win7 Pro 64-Bit. The behavior of FF - installed and portable version - is on several PCs all the same.

I'll do install the English portable version as next step and give it a try and post the results here.

more options

In the meantime I installed FF36.0.1 portable English-version with no add-ons at all, no changes in whatever prefs. just out of the box.

It is still the same: with (browser.preferences.inContent=true), changes in proxy settings do not get stored on «OK». For example open Proxy settings menu, change from «No Proxy» to «Manual Proxy Configuration:» press «OK». Open Proxy settings again and «No Proxy» ist markt as active again. With (browser.preferences.inContent=false), proxy changes get stored on «OK».

more options

Some protection programs can lock settings and even remove things like history, data, and so on. Open the settings for these programs, and tell them to leave the browsers alone.

more options

@FedMcD So you suggest, those protection programs do block things depending on (browser.preferences.inContent=true or false)?!?

Sorry, I don't think so.

more options

Ausgewählte Lösung

With FF38.0 and «settings in tab» activatet per default, the mentioned problem with not safed proxi settings is not there anymore.

So it seems to be solved.

more options

That was very good work. Well Done.