Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Thunderbird Time Formatting not matching system

  • 8 svar
  • 2 har dette problem
  • 70 visninger
  • Seneste svar af Chuck

more options

I am running Thunderbird on Linux, using version 91.4.1 (64-bit). My OS is set to use a 12 hour clock, yet all times in Thunderbird use a 24 hour clock. I checked out the help article, and it seemed to indicate having the locale set to English (United States) in preferences should get me the 12 hour clock, but both Application locale and Regional settings locale show that option. Switching does not change anything. I tried looking in the config editor, but I was unable to locate any of the settings to change time formats mentioned in the help article.

Why is Thunderbird stuck on a 24 hour clock?

The help article I tried: https://support.mozilla.org/en-US/kb/customize-date-time-formats-thunderbird

I am running Thunderbird on Linux, using version 91.4.1 (64-bit). My OS is set to use a 12 hour clock, yet all times in Thunderbird use a 24 hour clock. I checked out the help article, and it seemed to indicate having the locale set to English (United States) in preferences should get me the 12 hour clock, but both Application locale and Regional settings locale show that option. Switching does not change anything. I tried looking in the config editor, but I was unable to locate any of the settings to change time formats mentioned in the help article. Why is Thunderbird stuck on a 24 hour clock? The help article I tried: https://support.mozilla.org/en-US/kb/customize-date-time-formats-thunderbird
Vedhæftede skærmbilleder

Valgt løsning

I figured it out, I think. I was using the flatpak version of Thunderbird instead of the binary from the repos (I was trying to use the latest version). I would guess that, because flatpaks run in a container, Thunderbird couldn't tell what my system clock settings were, so it defaulted to a 24 hour time format.

After switching away from the flatpak version, the times in Thunderbird now follows the rest of my system for formatting.

Læs dette svar i sammenhæng 👍 0

Alle svar (8)

more options

what does your Linux system tell you when you query the TZ variable?

more options

Matt said

what does your Linux system tell you when you query the TZ variable?

i get nothing from "echo $TZ", but "timedatectl" shows my Time zone as America/New_York (EST, -0500), and "date" shows my date and time like i expect it/would like it to if it helps, I'm using Pop!_OS 21.10, an Ubuntu based distribution

$ echo $TZ

$ timedatectl

              Local time: Tue 2021-12-28 13:22:21 EST
          Universal time: Tue 2021-12-28 18:22:21 UTC
                RTC time: Tue 2021-12-28 18:22:20
               Time zone: America/New_York (EST, -0500)

System clock synchronized: yes

             NTP service: active
         RTC in local TZ: no

$ date Tue Dec 28 01:28:26 PM EST 2021

more options
more options

christ1 said

See if this helps. https://askubuntu.com/questions/1038952/how-to-change-time-display-to-12h-time-format-in-ubuntu

I had a look at the help article, and I've already got GNOME set in the 12h format. The only app I can see that is still showing things in 24h format is Thunderbird.

The dconf-editor tool in the article looks useful though, thanks for that.

more options

I have the same problem. It is not global, in that my OS displays civilian (12-hour) format rather than military (24-hour) format. My Thunderbird client did the same thing to, at least until the last update which broke it. Developers: Please fix your mistake as I am not in the military and prefer Thunderbird time match my system.

more options

firefox1715 said

I have the same problem. It is not global, in that my OS displays civilian (12-hour) format rather than military (24-hour) format. My Thunderbird client did the same thing to, at least until the last update which broke it. Developers: Please fix your mistake as I am not in the military and prefer Thunderbird time match my system.

Are you using Linux? This topic is about the Linux operating system and how to make it report time to Thunderbird in a 12hour or 24 hour format. Even then you would perhaps need to be using the same distribution, as not all distributions are created equal.

more options

Valgt løsning

I figured it out, I think. I was using the flatpak version of Thunderbird instead of the binary from the repos (I was trying to use the latest version). I would guess that, because flatpaks run in a container, Thunderbird couldn't tell what my system clock settings were, so it defaulted to a 24 hour time format.

After switching away from the flatpak version, the times in Thunderbird now follows the rest of my system for formatting.

more options

I'm running LinuxMint 20.3 with Thunderbird 91.* and I'm getting the same issue. Now, it was normal until I got an update. Then after that I noticed the time. Here is what I'm showing for system time. chuck@chuck-OptiPlex-3010:~$ echo $TZ

chuck@chuck-OptiPlex-3010:~$ timedatectl

              Local time: Mon 2022-06-06 16:22:14 PDT     
          Universal time: Mon 2022-06-06 23:22:14 UTC     
                RTC time: Mon 2022-06-06 23:22:14         
               Time zone: America/Los_Angeles (PDT, -0700)

System clock synchronized: yes

             NTP service: active                          
         RTC in local TZ: no                              

chuck@chuck-OptiPlex-3010:~$ date Mon 06 Jun 2022 04:22:36 PM PDT chuck@chuck-OptiPlex-3010:~$

I've read the articles tried a few things and I'm about to the point of removing it from my system and loading again. But it would be nice if there was a fix other than that. Not sure if that would help at this point. It should be noted that ALL other applications are using 12Hr format only Thunderbird is locked to 24hr. If it's getting the time from the system and the system is 12hr, sure seems like Thunderbird now has a mind of its own.