Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Disable calendar and task on 78.2.2

  • 19 svar
  • 7 har dette problem
  • 204 visninger
  • Seneste svar af ZetiX

more options

On previous versions, removing the lightning extension will remove the calendar and tasks. But with v78, I don't see the option to disable them.

Valgt løsning

For anyone wanting to remove the calendar and task icons, create a userChrome.css and place the following:

   #tabbar-toolbar[currentset="calendar-tab-button,task-tab-button"] {
     display: none;
   }

To remove the show today panel on bottom right status bar as well, add the following:

   #calendar-show-todaypane-panel[id="calendar-show-todaypane-panel"] {
     display: none;
   }
Læs dette svar i sammenhæng 👍 1

Alle svar (19)

more options

Lightning is no longer an extension, it became an integrated part of Thunderbird. If the icons on the window are bothering you, you can remove them by right clicking them, then choosing Personalize.

Nyttig?

more options

That doesn't appear to be an option.

Nyttig?

more options

He means customize. But that won't do it either.

Let's just say, someone is looking at it, and there is some future work to be done.

Nyttig?

more options

Please also add option to actually disable the feature from the menu. I do not use it and do not want it taking up memory space on my laptop.

Nyttig?

more options

With integrating calendar into Thunderbird as has not happened, there is a need to provide an off/on option added to Options>Calendar. That option will remove the calendar and task buttons from the toolbar on the upper right as well as not load the calendar portion of the program unless and until the user turns it back on. Thank you.

Nyttig?

more options

Valgt løsning

For anyone wanting to remove the calendar and task icons, create a userChrome.css and place the following:

   #tabbar-toolbar[currentset="calendar-tab-button,task-tab-button"] {
     display: none;
   }

To remove the show today panel on bottom right status bar as well, add the following:

   #calendar-show-todaypane-panel[id="calendar-show-todaypane-panel"] {
     display: none;
   }

Nyttig?

more options

I keep hitting issues and use another calendar so want to disable it.

Ændret af steve17 den

Nyttig?

more options

While it's nice to have an integrated calendar. many (most?) users already have one (or more) calendars, so they don't need another one. Tbird is a messaging program. Make the calendar an option. If people like it, they'll stick with it. If not, well, that's the crumbling cookie on your plate.

Nyttig?

more options

I'm also trying to get rid of the calendar and tasks and considering it's not possible to uninstall them, I've tried writing the following under `~/.thunderbird/xh2tgd9v.default/storage/permanent/chrome/userChrome.css` and `~/.thunderbird/xh2tgd9v.default/chrome`: ```

  1. tabbar-toolbar[currentset="calendar-tab-button,task-tab-button"] {

display: none; } ```

Yet Thunderbird still shows on the top right those two annoying icons for calendar and tasks. It's absurd that you can't get rid of them at least visually as if they were just another addon, I don't see how the user benefits from being forced to use or see something.

Ændret af Undercover den

Nyttig?

more options

You have to create it in the profile's folder.

On thunderbird, click on the hamburger icon -> Help -> Troubleshooting Information -> Open Folder next to Profile Folder.

Nyttig?

more options

ZetiX said

You have to create it in the profile's folder. On thunderbird, click on the hamburger icon -> Help -> Troubleshooting Information -> Open Folder next to Profile Folder.

Thanks for the help, but putting the file in `~/.thunderbird/xh2tgd9v.default/profile/chrome/userChrome.css` doesn't work either.

When opening the profile's folder from the "Troublesooting Information", the button next to "Profile Directory", it simply opens the `~/.thunderbird/xh2tgd9v.default` folder, where I've created the subfolders `profile/chrome`.

Nyttig?

more options

Did you enable css support the config?

Nyttig?

more options

No I hadn't, didn't know that was thing.

After looking for how to enable the last comment from this thread said to enable the `toolkit.legacyUserProfileCustomizations.stylesheets` in the config editor, which is now currently set to true.

Restarting ThunderBird showed that the two icons still remain.

To make sure that I haven't made an error in the config, here's the exact output of running the `cat` command:

$ cat .thunderbird/xh2tgd9v.default/profile/chrome/userChrome.css

#tabbar-toolbar[currentset="calendar-tab-button,task-tab-button"] {
     display: none;
}

Ændret af Undercover den

Nyttig?

more options

Try this:

   #tabbar-toolbar {
     display: none !important;
   }
   #calendar-show-todaypane-panel {
     display: none !important;
   }

Nyttig?

more options

Nope still nothing, I must be doing something wrong, but I'm sure this is the default profile because in `~/.thunderbird` there's only one directory and hence one profile.

Could it be from my addons? Here's a list of my current addons: - Automatic Dictionary - Hide Local Folders for TB78++ - Manually Sort Folders

There only one that has permissions is the Automatic Dictionary with: - Read and modify your address books and contacts - Read and modify your email messages as you compose and send them

I'm also using the default TB theme with operating system colors. I should probably say that I'm running Manjaro, although I don't expect that to make a change.

Nyttig?

more options

Can you double check the profile location through TB?

If the config is set and the profile location is correct, then I'm not really sure what the issue is.

Nyttig?

more options

Okay so instead of `~/.thunderbird/xh2tgd9v.default/profile/chrome/userChrome.css` I now have `~/.thunderbird/xh2tgd9v.default/chrome/userChrome.css`, as the folder `xh2tgd9v.default` is the one that is opened when I click on the profile button on TB.

However using the previous userChrome.css:

  #tabbar-toolbar {
    display: none !important;
  }
  #calendar-show-todaypane-panel {
    display: none !important;
  }

Removes all of my toolbar on the right (https://i.imgur.com/WoQbgDI.png). And using the userChrome.css that was provided as solution in this thread doesn't do anything and it shows the entire bar (https://i.imgur.com/QWJMoJw.png).

This is not a game changer but having the option to have only the desired options in the toolbar, in my case the search, new email and the menu symbol, would be great and I don't see how come we have to use a custom css to get something as basic done.

Thanks for your help, I'll keep looking untill i find the answer.

Nyttig?

more options

It says that my message has to be mod approved for some reason (maybe because it had links for images) but TL;DR now my entire right menu (calendar, tasks and burger menu) are gone, all I did was move the file to `/home/undercover/.thunderbird/xh2tgd9v.default/chrome/userChrome.css`.

Nyttig?

more options

Undercover said

Okay so instead of `~/.thunderbird/xh2tgd9v.default/profile/chrome/userChrome.css` I now have `~/.thunderbird/xh2tgd9v.default/chrome/userChrome.css`, as the folder `xh2tgd9v.default` is the one that is opened when I click on the profile button on TB. However using the previous userChrome.css: #tabbar-toolbar { display: none !important; } #calendar-show-todaypane-panel { display: none !important; } Removes all of my toolbar on the right (https://i.imgur.com/WoQbgDI.png). And using the userChrome.css that was provided as solution in this thread doesn't do anything and it shows the entire bar (https://i.imgur.com/QWJMoJw.png). This is not a game changer but having the option to have only the desired options in the toolbar, in my case the search, new email and the menu symbol, would be great and I don't see how come we have to use a custom css to get something as basic done. Thanks for your help, I'll keep looking untill i find the answer.

You'll have to find the css id of the icons on your own as I don't have the exact setup you do (https://i.imgur.com/UdQBwlw.png). To get the css id, press CTRL + SHIFT + I and accept the incoming local connection. Then click the icon next to the Inspector tab on the new window. This will allow you to point at the icons you want on Thunderbird and show you the CSS id that you need to replace `#tabbar-toolbar {`. If you still need help, just copy and paste the CSS code here.

Nyttig?

Stil et spørgsmål

Du skal logge ind på din konto for at svare på et indlæg. Start et nyt spørgsmål, hvis du ikke har en konto endnu.