X
Tryk her for at gå til webstedets mobilversion.

Supportforum

In Linux Mint can I disable the search dropdown in the urlbar?

Skrevet

Hello - I am running the latest Mint/FFx 71 and I am typing an address in the urlbar and it suggest a site or search with a drop down just below the urlbar. I have turned off search suggestions. Tried disabling all of the urlbar items in about:config and even created a userAcccount.css file in a chrome folder in my user profile. Nothing seems to work.

Is there a way to disable this?

Hello - I am running the latest Mint/FFx 71 and I am typing an address in the urlbar and it suggest a site or search with a drop down just below the urlbar. I have turned off search suggestions. Tried disabling all of the urlbar items in about:config and even created a userAcccount.css file in a chrome folder in my user profile. Nothing seems to work. Is there a way to disable this?

Valgt løsning

Here you go:

Open about:config and find the pref toolkit.legacyUserProfileCustomizations.stylesheets and make it true.

Open your profile folder. Use about:support if that makes it easier.

Close Firefox.

Create a directory /chrome in your profile directory if it does not exist.

Create a new text file to be saved as userChrome.css in that directory.

Paste this in the file and save it:


#urlbar-results { display:none; 
}

restart teh Firefox and let us know how you get on. :)

Læs dette svar i sammenhæng 1
Citér

Yderligere systemdetaljer

Program

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

Yderligere information

Luk
crankygoat
  • Top 25 Contributor
31 løsninger 338 svar

In Preferences where you turned off Search Suggestions, click the link below entitled "Change preferences for browsing history, bookmarks, and tab suggestions", and clear these checkboxes as well.

In Preferences where you turned off Search Suggestions, click the link below entitled "Change preferences for browsing history, bookmarks, and tab suggestions", and clear these checkboxes as well.
Fandt du dette nyttigt?
Citér

Spørgsmålsstiller

Yes I have cleared those also. I still get the dropdown.

Yes I have cleared those also. I still get the dropdown.
Fandt du dette nyttigt?
Citér
crankygoat
  • Top 25 Contributor
31 løsninger 338 svar

Oh, blergh.

Maybe some of the search prefs are stuck or borked? You mentioned the URL bar prefs; did you look at the items when searching browser.prefs in about:config?

Pics attached to show my settings and the effect.

Oh, blergh. Maybe some of the search prefs are stuck or borked? You mentioned the URL bar prefs; did you look at the items when searching '''browser.prefs''' in about:config? Pics attached to show my settings and the effect.
Fandt du dette nyttigt?
Citér

Spørgsmålsstiller

Unfortunately all the settings are verified and I still have the dropdown. In your last pic it shows the dropdown = beepboop searching duckduckgo.

That's what I want to get rid of :)

I was able to do this before on my windows machines by changing prefs in about:config, modifying settings and then ultimately creating a css file.

I would think if you could modify FF in Windows, you should be able to tweak in a sort of similar fashion for Linux.

I will continue to try a few more things. . . . appreciate your help.

Unfortunately all the settings are verified and I still have the dropdown. In your last pic it shows the dropdown = beepboop searching duckduckgo. That's what I want to get rid of :) I was able to do this before on my windows machines by changing prefs in about:config, modifying settings and then ultimately creating a css file. I would think if you could modify FF in Windows, you should be able to tweak in a sort of similar fashion for Linux. I will continue to try a few more things. . . . appreciate your help.
Fandt du dette nyttigt?
Citér
crankygoat
  • Top 25 Contributor
31 løsninger 338 svar

You want to see absolutely zero dropdown? I'll have a poke and see which setting it may be. I had intended it to be a guide if you had not seen all those prefs before. I hadn't tried to turn off all of them yet.

edit: I know where it lives. Working on a way to silence it.

You want to see absolutely zero dropdown? I'll have a poke and see which setting it may be. I had intended it to be a guide if you had not seen all those prefs before. I hadn't tried to turn off all of them yet. edit: I know where it lives. Working on a way to silence it.

Ændret af crankygoat den

Fandt du dette nyttigt?
Citér
crankygoat
  • Top 25 Contributor
31 løsninger 338 svar

Valgt løsning

Here you go:

Open about:config and find the pref toolkit.legacyUserProfileCustomizations.stylesheets and make it true.

Open your profile folder. Use about:support if that makes it easier.

Close Firefox.

Create a directory /chrome in your profile directory if it does not exist.

Create a new text file to be saved as userChrome.css in that directory.

Paste this in the file and save it:


#urlbar-results { display:none; 
}

restart teh Firefox and let us know how you get on. :)

Here you go: Open '''about:config''' and find the pref '''toolkit.legacyUserProfileCustomizations.stylesheets''' and make it '''true'''. Open your profile folder. Use '''about:support''' if that makes it easier. Close Firefox. Create a directory '''/chrome''' in your profile directory if it does not exist. Create a new text file to be saved as '''userChrome.css''' in that directory. Paste this in the file and save it: <pre><code> #urlbar-results { display:none; } </code></pre> restart teh Firefox and let us know how you get on. :)

Ændret af crankygoat den

Fandt du dette nyttigt? 1
Citér

Nyttigt svar

Excellent worked like a charm! I already re-used my userChrome.css I created before with this line:

"#urlbar-results { display:none; }"

what made the difference was changing:

toolkit.legacyUserProfileCustomizations.stylesheets to TRUE

Thanks so much, knew it had to be some minor toggle and a file :)

Excellent worked like a charm! I already re-used my userChrome.css I created before with this line: "#urlbar-results { display:none; }" what made the difference was changing: '''toolkit.legacyUserProfileCustomizations.stylesheets''' to TRUE Thanks so much, knew it had to be some minor toggle and a file :)

Ændret af henryspr1 den

Fandt du dette nyttigt? 1
Citér
crankygoat
  • Top 25 Contributor
31 løsninger 338 svar

Aha, good deal. I am glad some part of that process worked for you.

Also thanks for paring down the entry to only what is necessary, I wouldn't have guessed it was that minimal from inspecting chrome and the style entries i found after looking it up. The other entry people were including at the top of their css wasn't necessary, either. Will edit my previous post to reflect that.

Aha, good deal. I am glad some part of that process worked for you. Also thanks for paring down the entry to only what is necessary, I wouldn't have guessed it was that minimal from inspecting chrome and the style entries i found after looking it up. The other entry people were including at the top of their css wasn't necessary, either. Will edit my previous post to reflect that.
Fandt du dette nyttigt?
Citér
Stil et spørgsmål

Du skal logge ind på din konto for at svare på et indlæg. Start et nyt spørgsmål, hvis du ikke har en konto endnu.