X
Tryk her for at gå til webstedets mobilversion.

Supportforum

Open external links in private-window

Skrevet

On Windows, Firefox adds a pre-set command line to the Windows registry under

   HKEY_CLASSES_ROOT\FirefoxHTML\shell\open\command
   HKEY_CLASSES_ROOT\FirefoxURL\shell\open\command 

If you change the -url in the command line to -private-window -- from

"C:\Program Files (x86)\Mozilla Firefox\firefox.exe" -osint -url "%1"

to

"C:\Program Files (x86)\Mozilla Firefox\firefox.exe" -osint -private-window "%1"

-- then all external links launch in a private window.


jscher2000 in https://support.mozilla.org/en-US/questions/1119073

This no longer works in FF 69. As soon as I modify "HKEY_CLASSES_ROOT\FirefoxURL-F66A7FFE1BF331E2\shell\open\command", FF is detecting it and changes its status to "NOT your default browser".

I'd appreciate your help.

On Windows, Firefox adds a pre-set command line to the Windows registry under HKEY_CLASSES_ROOT\FirefoxHTML\shell\open\command HKEY_CLASSES_ROOT\FirefoxURL\shell\open\command If you change the -url in the command line to -private-window -- from "C:\Program Files (x86)\Mozilla Firefox\firefox.exe" -osint -url "%1" to "C:\Program Files (x86)\Mozilla Firefox\firefox.exe" -osint -private-window "%1" -- then all external links launch in a private window. --------- jscher2000 in https://support.mozilla.org/en-US/questions/1119073 This no longer works in FF 69. As soon as I modify "HKEY_CLASSES_ROOT\FirefoxURL-F66A7FFE1BF331E2\shell\open\command", FF is detecting it and changes its status to "NOT your default browser". I'd appreciate your help.

Ændret af Yaron den

Valgt løsning

@radar81,

Yes, I've found a solution.

Use:

[HKEY_CLASSES_ROOT\FirefoxHTML-F66A7FFE1BF441E2\shell\open\command] @="\"C:\\Program Files\\Mozilla Firefox New\\firefox.exe\" -private-window \"%1\""

[HKEY_CLASSES_ROOT\FirefoxURL-F66A7FFE1BF441E2\shell\open\command] @="\"C:\\Program Files\\Mozilla Firefox New\\firefox.exe\" -private-window \"%1\""

Replace the path and "-F66A7FFE1BF441E2" with your strings.

The status in FF preferences will change to "NOT your default browser" but *it will actually remain the default browser*.

Regards.

Læs dette svar i sammenhæng 1
Citér

Yderligere systemdetaljer

Installerede plugins

  • Shockwave Flash 32.0 r0

Program

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:69.0) Gecko/20100101 Firefox/69.0

Yderligere information

Luk
radar81 0 løsninger 6 svar

I am also wanting to do set external links to launch in a private window by default. I also tried the same solution proposed by jscher2000 in https://support.mozilla.org/en-US/questions/1119073 and found that it no longer works. Were you able to find a solution? Thanks!

I am also wanting to do set external links to launch in a private window by default. I also tried the same solution proposed by jscher2000 in https://support.mozilla.org/en-US/questions/1119073 and found that it no longer works. Were you able to find a solution? Thanks!
Fandt du dette nyttigt?
Citér

Valgt løsning

@radar81,

Yes, I've found a solution.

Use:

[HKEY_CLASSES_ROOT\FirefoxHTML-F66A7FFE1BF441E2\shell\open\command] @="\"C:\\Program Files\\Mozilla Firefox New\\firefox.exe\" -private-window \"%1\""

[HKEY_CLASSES_ROOT\FirefoxURL-F66A7FFE1BF441E2\shell\open\command] @="\"C:\\Program Files\\Mozilla Firefox New\\firefox.exe\" -private-window \"%1\""

Replace the path and "-F66A7FFE1BF441E2" with your strings.

The status in FF preferences will change to "NOT your default browser" but *it will actually remain the default browser*.

Regards.

@radar81, Yes, I've found a solution. Use: [HKEY_CLASSES_ROOT\FirefoxHTML-F66A7FFE1BF441E2\shell\open\command] @="\"C:\\Program Files\\Mozilla Firefox New\\firefox.exe\" -private-window \"%1\"" [HKEY_CLASSES_ROOT\FirefoxURL-F66A7FFE1BF441E2\shell\open\command] @="\"C:\\Program Files\\Mozilla Firefox New\\firefox.exe\" -private-window \"%1\"" Replace the path and "-F66A7FFE1BF441E2" with your strings. The status in FF preferences will change to "NOT your default browser" but *it will actually remain the default browser*. Regards.

Ændret af Yaron den

Fandt du dette nyttigt? 1
Citér
radar81 0 løsninger 6 svar

@Yaron It works, thanks so much!

@Yaron It works, thanks so much!
Fandt du dette nyttigt?
Citér

Spørgsmålsstiller

You're welcome.

You're welcome.
Fandt du dette nyttigt?
Citér
Stil et spørgsmål

Du skal logge ind på din konto for at svare på et indlæg. Start et nyt spørgsmål, hvis du ikke har en konto endnu.