Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

First page typed in address bar doesn't load

  • 6 svar
  • 1 har dette problem
  • 13 visninger
  • Seneste svar af cor-el

more options

For some time now, I have noticed that if Firefox is not open and I click on a URL in an email or somewhere else, Firefox will open but the address bar goes blank and the page does not load. If I click on the link again, another window opens and the page seems to load fine. The same thing happens if I open Firefox and type a simplified URL (like www.xyz.com). It does not seem to be related to add-ons being enabled or disabled.

Valgt løsning

Opening hyperlink from a right-click still behaves the same. I did try disabling the Windscribe add-in and this seems to work much better. I will close this question and pursue it with Windscribe. Thanks for your suggestions.

Læs dette svar i sammenhæng 👍 0

Alle svar (6)

more options

Where are you opening these links from?

Let's try an experiment. Before clicking a link, hold down the <Shift> key. Is the problem still there?


Type about:preferences#general<enter> in the address bar. Turn on Make Firefox Default Browser. You can also turn on; Always Check Firefox Default Browser.

more options

Hi, here is some more information and test results. I am opening links from Outlook 2013 email messages. Since Firefox opens when I click on the link, it seems that the default apps are configured properly. The problem also happens if I open Firefox manually and type a URL directly into the address bar. If I hold down Shift, all that happens is that the link text is selected, and the link is not opened. I tried quitting the Windscribe VPN (app, not browser plug-in) instead of "disconnecting" and the problem seemed to go away, but it came back. There may be some network-related issue, since sometimes I have to disable and re-enable my Ethernet adapter. All drivers and OS versions are fully updated.

more options

Right-click the link, hold down <Shift> then select Open In Browser or whatever.

more options

Valgt løsning

Opening hyperlink from a right-click still behaves the same. I did try disabling the Windscribe add-in and this seems to work much better. I will close this question and pursue it with Windscribe. Thanks for your suggestions.

more options

How do you open the link if you "If I hold down Shift" ? Is this with the Enter key or do yo7 click the mouse of the Go (right pointing arrow) button?

more options