Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't Choose a Different Search option!!

  • 5 svar
  • 2 har dette problem
  • 7 visninger
  • Seneste svar af FredMcD

more options

With the last update, I noticed my default search engine went to Google. I went back into my settings and I am only able to chose what is provided in the list. Are we not able to actually CHOOSE which search engine (except what is listed as choices)? I use one not in their list.

Valgt løsning

Actually, I ended up doing a reset. When I added the search engine button (that I use) to the toolbar, it suddenly gave me the option to add it as default. Strange, but that worked! Thanks for you help, though! If it goes again, I will try what you've said :)

Læs dette svar i sammenhæng 👍 0

Alle svar (5)

more options

To reset the search engines, remove these files in the Firefox profile folder; search.json + search-metadata.json + search.sqlite + search.json.mozlz4

search.json.mozlz4 ==only== (v45+)

New files are created when needed.

Type about:support<enter> in the address bar.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Locate the above file. Then rename or delete it. Restart Firefox.

more options

FredMcD said

To reset the search engines, remove these files in the Firefox profile folder; search.json + search-metadata.json + search.sqlite + search.json.mozlz4 search.json.mozlz4 ==only== (v45+) New files are created when needed. Type about:support<enter> in the address bar. Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox. Locate the above file. Then rename or delete it. Restart Firefox.


I forgot to mention I'm on a Mac :( Appreciate your help!

more options

Use the same directions.

more options

Valgt løsning

Actually, I ended up doing a reset. When I added the search engine button (that I use) to the toolbar, it suddenly gave me the option to add it as default. Strange, but that worked! Thanks for you help, though! If it goes again, I will try what you've said :)

more options

That was very good work. Well done. Please flag your last post as Solved Problem so others will know.