Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

regarding Google as my default search engine

  • 9 svar
  • 3 har dette problem
  • 317 visninger
  • Seneste svar af cor-el

more options

I have switched my default search engine to google. but every time I open Firefox, I continue to get the extra little window giving me instructions on how to do it again. it's driving my perfectionist ocd crazy. plz help. lol

Valgt løsning

I think that this is saved in a cookie with the name OGP and possibly OGPC. So make sure you keep cookies from google.com.

Such a detail is stored in a cookie.

  • You can create a cookie "Allow" exception to keep specific cookies, especially in case of secure websites and when cookies expire when Firefox is closed.
  • Tools > Options > Privacy > "Use custom settings for history" > Cookies: Exceptions

In case you use "Clear history when Firefox closes" or otherwise clear history.

  • do not clear the Cookies
  • do not clear the Site Preferences
  • clearing "Site Preferences" clears exceptions for cookies, images, pop-up windows, and software installation and exception for password and other website specific data
  • clearing cookies will remove all selected cookies including cookies with an "Allow" exception you may want to keep
Læs dette svar i sammenhæng 👍 0

Alle svar (9)

more options

What is your computer system and Firefox?

I don't know if this can help,

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

more options

Do you have a Google page set as your Homepage in Firefox?

That message appears in Firefox at many Google pages. Google doesn't know that you have Google search as your default, it just knows that you're using Firefox and may have a different search engine set as your default.

IMO, they're acting juvenileand "acting out", because after a decade of Google being the "default" in Firefox for all locales around the globe Mozilla decided earlier this year to use a number of different search engines depending upon the locale of the user and based upon which localized version of Firefox they have installed.

more options

windows 10, on a Dell inspiron 3000 series. the latest Firefox idk lol. article doesn't help, cuz the default search engine is Google when I open it, it remembers the setting.. as far as I can tell anyway..

more options

Google is my default home as well yes, when it wasn't i'd get a lil window that asked me if I wanted to switch my homepage lol. I just want it to recognize Google is my default everything & just stop asking ugh lol.. nobody representing Firefox can/will offer any support..?

more options

Can you attach a screenshot to make sure we understand what you see?

  • Use a compressed image type like PNG or JPG to save the screenshot
  • Make sure that you do not exceed the maximum size of 1 MB

Ændret af cor-el den

more options

Google is my homepage. However, I keep getting a nag about "get to google faster" when I'm already there. How do I get rid of this?

more options

Valgt løsning

I think that this is saved in a cookie with the name OGP and possibly OGPC. So make sure you keep cookies from google.com.

Such a detail is stored in a cookie.

  • You can create a cookie "Allow" exception to keep specific cookies, especially in case of secure websites and when cookies expire when Firefox is closed.
  • Tools > Options > Privacy > "Use custom settings for history" > Cookies: Exceptions

In case you use "Clear history when Firefox closes" or otherwise clear history.

  • do not clear the Cookies
  • do not clear the Site Preferences
  • clearing "Site Preferences" clears exceptions for cookies, images, pop-up windows, and software installation and exception for password and other website specific data
  • clearing cookies will remove all selected cookies including cookies with an "Allow" exception you may want to keep
more options

There are 2 Google cookies:

<root><item name="og-up-OGPL" value="5084034" ltime="4124429216" htime="30515854" /></root>

NID = 79=NrKuPqvrs1G9P8dRnPb77K1_2zL4QoCnUURnpf2dkGKTP2-9MQ9bUX2yiDejal1Cbq8ohvpJLom4YM5hbR8YLpG4zzuni69cOGCulAh_FOLg2zL-fS5JwT_uqBYXVAPmhG95CnIWIl6eX2M OGPC = 5062071-1:

are either of these what you were referring to?

Only other cookie is Doubleclick.

more options

I Think that the OGPC = 5061821-1: cookie stores that you have seen the alert. If I close the alert with the X then I get an OGP cookie with a minus sign: OGP = -5061821: If I remove this OGP cookie then the alert reappear, so it looks this this happens in your case if you keep seeing it.