X
Klepněte zde pro přechod na mobilní verzi webu.

Fórum podpory

Jak mám obnovit Firefox do stavu, ve kterém byl před onou chybou s vypínáním doplňků ze 4. května 2019?

Přidáno

Nechci instalovat novou verzi, chci to obnovit do původního stavu s doplňky, které mi fungovaly před pár dny.

Nechci instalovat novou verzi, chci to obnovit do původního stavu s doplňky, které mi fungovaly před pár dny.
Citovat

Další informace o systému

Nainstalované zásuvné moduly

  • Shockwave Flash 29.0 r0

Aplikace

  • Identifikace prohlížeče: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0

Více informací

poljos 180 řešení 1613 odpovědí
Přidáno

Pokud si nainstaluješ (zaktualizuješ) Firefox na aktuální verzi 66.0.4, tak se ty doplňky zase samy zapnou.

Pokud si nainstaluješ (zaktualizuješ) Firefox na aktuální verzi 66.0.4, tak se ty doplňky zase samy zapnou.
Bylo to pro vás srozumitelné? 0
Citovat

Autor otázky

To je právě ono, jak jsem psal, že já nechci novou verzi FF. Já jsem spokojen s verzí 56.0.2. Nemusím si s každou druhou verzí zvykat na jiný vzhled a nové umístění ovládacích prvků. Také adblock se mi zdá přehlednější před tou novou verzí Quantum (57). Když se objevila verze 57 a přestalo mi všechno fungovat, tak jsem se vrátil k verzi 56 a od té doby se jí držím jako helvétské víry.

To je právě ono, jak jsem psal, že já nechci novou verzi FF. Já jsem spokojen s verzí 56.0.2. Nemusím si s každou druhou verzí zvykat na jiný vzhled a nové umístění ovládacích prvků. Také adblock se mi zdá přehlednější před tou novou verzí Quantum (57). Když se objevila verze 57 a přestalo mi všechno fungovat, tak jsem se vrátil k verzi 56 a od té doby se jí držím jako helvétské víry.
Bylo to pro vás srozumitelné?
Citovat
poljos 180 řešení 1613 odpovědí
Přidáno

V tom případě si projdi včerejší a předvčerejší dotazy tady ve fóru. https://support.mozilla.org/cs/questions/firefox?show=all

V tom případě si projdi včerejší a předvčerejší dotazy tady ve fóru. https://support.mozilla.org/cs/questions/firefox?show=all
Bylo to pro vás srozumitelné? 0
Citovat

Autor otázky

Asi se blbě orientuji, ale nic tam nenacházím. Zkusím to tedy jinak.

Mám z ledna zálohu profilu udělanou pomocí programu mozbackup. Když tu zálohu použiji, tak se mi obnoví profil, v němž mám adblock a další doplňky, které fungovaly před májovou katastrofou. Ale mám pochopitelně otevřené jiné panely - ty, které jsem měl orevřené v lednu.

Co zaškrtnout v mozbackupu, aby se mi obnovily pouze doplňky, ale aby mi zůstaly panely, které mám otevřené dnes?

Asi se blbě orientuji, ale nic tam nenacházím. Zkusím to tedy jinak. Mám z ledna zálohu profilu udělanou pomocí programu mozbackup. Když tu zálohu použiji, tak se mi obnoví profil, v němž mám adblock a další doplňky, které fungovaly před májovou katastrofou. Ale mám pochopitelně otevřené jiné panely - ty, které jsem měl orevřené v lednu. Co zaškrtnout v mozbackupu, aby se mi obnovily pouze doplňky, ale aby mi zůstaly panely, které mám otevřené dnes?
Bylo to pro vás srozumitelné?
Citovat
poljos 180 řešení 1613 odpovědí
Přidáno

Já jsem ten tvůj dotaz pochopil tak, že chceš zprovoznit doplňky, které byly zablokované toho 2. května. MozBackup nepoužívám, takže moc neporadím. Já bych to řešil asi tak, že bych se odpojil od internetu a pak "ručně" při zavřeném Firefoxu překopíroval obsah složky extensions z té zálohy do současného profilu (opět do složky extensions).

Pokud se pamatuji, tak ta záloha je v nějakém formátu, ale je to v podstatě ZIP. Takže stačí přejmenovat příponu a rozbalit zálohu do nějaké složky. Odsud pak okopírovat ty doplňky (složka extensions). Všechno kopírovat při ukončeném Firefoxu!

Ten odpojený internet je důležitý, protože se Firefox po novém spuštění bude snažit aktualizovat kdeco (na nastevní Firefoxu se nedá moc spoléhat). Takže po spuštění si nejprve nastav možnosti aktualizace Firefoxu i doplňků podle sebe.

PS: Pravděpodobně by to mohlo jít i jinak. Zálohovat si soubory ve složce sessionstore-backups, provést obnovu z té zálohy a pak zpátky nakopírovat ty soubory ze sessionstore-backups, kde by měly být současné panely. Doporučuji používat i nějaký session manager, v tomto případě by se hodil.

Ovšem jsi o deset verzí Firefoxu pozadu...

Já jsem ten tvůj dotaz pochopil tak, že chceš zprovoznit doplňky, které byly zablokované toho 2. května. MozBackup nepoužívám, takže moc neporadím. Já bych to řešil asi tak, že bych se '''odpojil od internetu''' a pak "ručně" při '''zavřeném Firefoxu''' překopíroval '''obsah''' složky '''extensions''' z té zálohy do současného profilu (opět do složky extensions). Pokud se pamatuji, tak ta záloha je v nějakém formátu, ale je to v podstatě ZIP. Takže stačí přejmenovat příponu a rozbalit zálohu do nějaké složky. Odsud pak okopírovat ty doplňky (složka extensions). '''Všechno kopírovat při ukončeném Firefoxu!''' Ten odpojený internet je důležitý, protože se Firefox po novém spuštění bude snažit aktualizovat kdeco (na nastevní Firefoxu se nedá moc spoléhat). Takže po spuštění si nejprve nastav možnosti aktualizace Firefoxu i doplňků podle sebe. PS: Pravděpodobně by to mohlo jít i jinak. Zálohovat si soubory ve složce sessionstore-backups, provést obnovu z té zálohy a pak zpátky nakopírovat ty soubory ze sessionstore-backups, kde by měly být současné panely. Doporučuji používat i nějaký session manager, v tomto případě by se hodil. '''Ovšem jsi o deset verzí Firefoxu pozadu...'''

Upravil uživatel poljos dne

Bylo to pro vás srozumitelné?
Citovat
Michal Stanke
  • Moderator
182 řešení 990 odpovědí

Byl vydán Firefox 66.0.5, který opravil problémy s ověřováním doplňků z minulého týdne. V 66.0.4 se mohlo stát, že oprava nezafungovala kvůli zásahům ze strany antivirového programu.

Zároveň Mozilla potvrdila, že problém s doplňky opraví pro všechny verze od 52 výše.

Byl vydán Firefox 66.0.5, který opravil problémy s ověřováním doplňků z minulého týdne. V 66.0.4 se mohlo stát, že oprava nezafungovala kvůli zásahům ze strany antivirového programu. Zároveň Mozilla potvrdila, že problém s doplňky [https://www.mozilla.cz/zpravicky/problem-se-zakazanymi-doplnky-mozilla-vyresi-i-pro-stare-verze/ opraví pro všechny verze od 52 výše].
Bylo to pro vás srozumitelné?
Citovat
Položit otázku

Pro přidání odpovědi se musíte přihlásit ke svému účtu. Pokud dosud nemáte účet, položte novou otázku.