Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 90 doesn’t trust SSL/HTTPS certificate

  • 12 odgovori
  • 1 ima ovaj problem
  • 17 views
  • Posljednji odgovor poslao shoutje

more options

Although Chrome and Safari do open my site, Firefox 90 does not trust the HTTPS/SSL certificate.

Firefox 91, on the other hand, trusts the site again.

Cloudflare, the Dutch PoP, and my ISP working A-Okay.

Priloženi snimci ekrana

Izabrano rješenje

Update: problem solved after updating Firefox to 92.0.

... thanks to everyone for the previous responses !

Pročitajte ovaj odgovor sa objašnjenjem 👍 1

All Replies (12)

more options

No problems here and a certificate test on Qualys also doesn't report serious issues.

You can remove all data stored in Firefox for a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox for this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data for that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data for that website will be saved once again.


Try to rename the cert9.db file (cert9OLD.db) and remove the previously used cert8.db file in the Firefox profile folder with Firefox closed to remove intermediate certificates and exceptions that Firefox has cached.

If this has helped to solve the problem then you can remove the renamed cert9OLD.db file. Otherwise you can undo the rename and restore cert9.db.

You can use the button on the "Help -> More Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Helpful?

more options

Thank you for the feedback, did you manage to visit the site with Firefox 90 or 91 ?

I already have over 8 clients (Netherlands, Germany and Belgium ...) that have the same issue with my site using Firefox.

In other words, I can change things, but I can't expect all visitors to follow these steps to visit my site or to switch browsers such as Chrome or Safari as they work normally.

Helpful?

more options

I can replicate the issue in 90, but Nightly works.

Helpful?

more options

Thanks for replicating this problem jonzn4SUSE, this is appreciated, I look forward to cor-el's response ..

Helpful?

more options

There is something weird going on with the server. I now get this problem as well sometimes. What works for me is to reload and bypass the cache (Ctrl+F5) until the page loads properly (I sometimes get an unstyled page with no CSS applied). The Web Console shows in this case various errors about files that fail to load, so it is possible that there is a server overload that Firefox interprets as a failure to load the website (i.e. no certificate or other security issues).

EDIT: A normal reload (F5) gives the error in 90, but Ctrl+F5 works in most cases in 90. I haven't seen the error in 91 (beta).

Izmjenjeno od strane cor-el

Helpful?

more options

I did Ctrl+F5 and got this.

Helpful?

more options

You need to repeat Ctrl+F5 until you get the page displaying properly.

Helpful?

more options

I have not seen the issue in 90, but if this is on a Cloudflare CDN, we might be hitting different servers.

Helpful?

more options

cor-el said

You need to repeat Ctrl+F5 until you get the page displaying properly.

Just tried 10x and the site stays the same.

Helpful?

more options

Thank you,

Did it myself but doesn't work for me, I have to repeat Ctrl+F5 at every page I load to see it correctly but after that I have the same issue.

it's indeed a Cloudflare CDN but Safari en Chrome work A-Okay, what's going on with Firefox ?

Helpful?

more options

You can check the Web Console (Tools -> Web Developer) for messages about blocked content and about the presence of mixed or unsafe content.

You can check the Network Monitor to see if content is blocked or otherwise fails to load.

If necessary use "Ctrl+F5" or "Ctrl+Shift+R" (Mac: Command+Shift+R) to reload the page and bypass the cache to generate a fresh log.

Helpful?

more options

Odabrano rješenje

Update: problem solved after updating Firefox to 92.0.

... thanks to everyone for the previous responses !

Helpful?

Postavite pitanje

Morate se prijaviti na račun da biste odgovarali na poruke. Molimo postavite novo pitanje, ako još uvijek nemate račun.