সহায়তা খুঁজুন

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Link not working on Firefox, but is on Chrome and Safari

  • 2 উত্তরসমূহ
  • 0 এই সমস্যাটি আছে
  • 28 দেখুন
  • শেষ জবাব দ্বারা slschwe

more options

I don't think "Tabs" is the right topic, but maybe it's the best of the choices since "Other" isn't an option.

I have an email with a link to a monthly newsletter, which should take me to February's issue. When I click on, or copy/paste, the link, I end up with the January issue. When I copy/paste in Chrome and Safari, I get the February issue. The newsletter people suggested clearing my cache/cookies in Firefox, but that didn't help. No matter how I try to navigate to the newsletter in Firefox, I get to January. I have tried everything I can think of, and still get the January issue in Firefox, while that same link gets me the February issue in Safari and Chrome.

I'm using Firefox 122.0.1, on a MacBook Pro (Sonoma 14.2.1).

I'd appreciate any ideas you might have!


/edit: moved thread from Firefox for iOS (for iPhone/iPad) to Firefox section as you have macOS.

I don't think "Tabs" is the right topic, but maybe it's the best of the choices since "Other" isn't an option. I have an email with a link to a monthly newsletter, which should take me to February's issue. When I click on, or copy/paste, the link, I end up with the January issue. When I copy/paste in Chrome and Safari, I get the February issue. The newsletter people suggested clearing my cache/cookies in Firefox, but that didn't help. No matter how I try to navigate to the newsletter in Firefox, I get to January. I have tried everything I can think of, and still get the January issue in Firefox, while that same link gets me the February issue in Safari and Chrome. I'm using Firefox 122.0.1, on a MacBook Pro (Sonoma 14.2.1). I'd appreciate any ideas you might have! /edit: moved thread from Firefox for iOS (for iPhone/iPad) to Firefox section as you have <b>macOS</b>.

James দ্বারা পরিমিত

সমাধান চয়ন করুন

All Replies (2)

more options

চয়ন করা সমাধান

Does it still happen in Troubleshoot Mode?

Helpful?

more options

OMG thank you! The issue went away in troubleshoot mode, and then when I started up normally, it was gone. I only have two extensions, and was ready to disable them one at a time, but didn't need to. If you can explain why that would happen, I'd love to know. Either way -- thank you so much!

Helpful?

একটি প্রশ্ন জিজ্ঞাসা করুন

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.