সহায়তা খুঁজুন

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Japanese Input not appearing

  • 5 উত্তরসমূহ
  • 1 এই সমস্যাটি আছে
  • 11 দেখুন
  • শেষ জবাব দ্বারা zeroknight

more options

Since about one year I am unable to use Japanese input only in Firefox. When I try to switch with fcitx and control+space, nothing happens. However, fcitx-mocz works everywhere else on my computer (i.e. terminal, thunderbird, other browsers, etc.). Furthermore, I uninstalled fcitx and everything associated with it and reinstalled it according to this thread: https://support.mozilla.org/en-US/questions/1367181 (just with mocz for Japanese). This also didn't change anything. Any help is appreciated! My system: Operating System: Linux Mint 20.3 Kernel: Linux 5.15.0-91-generic Architecture: x86-64 fcitx version: 4.2.9.7 Mozilla Firefox 121.0

Since about one year I am unable to use Japanese input only in Firefox. When I try to switch with fcitx and control+space, nothing happens. However, fcitx-mocz works everywhere else on my computer (i.e. terminal, thunderbird, other browsers, etc.). Furthermore, I uninstalled fcitx and everything associated with it and reinstalled it according to this thread: https://support.mozilla.org/en-US/questions/1367181 (just with mocz for Japanese). This also didn't change anything. Any help is appreciated! My system: Operating System: Linux Mint 20.3 Kernel: Linux 5.15.0-91-generic Architecture: x86-64 fcitx version: 4.2.9.7 Mozilla Firefox 121.0

All Replies (5)

more options

Another user mentioned this recently however it works for me on Ubuntu 23.10.

Helpful?

more options

zeroknight schrieb

Another user mentioned this recently however it works for me on Ubuntu 23.10.


Unfortunately, this didn't help.

Paracelsus দ্বারা পরিমিত

Helpful?

more options

Try installing a different package format like flatpak.

Helpful?

more options

I've got a similar problem for over year now. I'm on MX Linux, with their packaged version of Firefox using the official binaries (firefox/mx,now 125.0~mozillabinaries-1mx23+1) as well as fcitx5-mozc. (I've also tried the ESR version from debian and I think even the flatpak) IME works like a charm (almost) everywhere else, including Thunderbird and the Tor browser. In Firefox however, it's like fcitx wasn't installed.

I took another swing at this and discovered that on a fresh Firefox profile, Japanese input does work as expected! So there has to be some setting somewhere in my profile that breaks IME. Incidentally, composing accented letters using the ` key also doesn't work in my old profile (I can't type accents at all, seemingly nothing happens when I press that key), but functions fine in a new one.

I've searched in about:settings and about:config for "input", "key" and "ime", but nothing caught my eye as a possible culprit. Please let me know if you have any idea which preferences I could try resetting! This profile has been with me for 9 years and 3 operating systems, and I'd like to avoid migrating my settings, add-ons and userchrome to a new one.

TL;DR: If your fcitx/ibus input methods don't work in Firefox despite everything being set up correctly and working everywhere else, try the following: - Go to about:profiles - Create a New Profile - Click the "Launch profile in new browser" button on the new profile - See if your input method works in the new profile

Helpful?

more options

Backup your profile folder and try renaming the prefs.js file to see if it is caused by an about:config setting.

Helpful?

একটি প্রশ্ন জিজ্ঞাসা করুন

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.