সহায়তা খুঁজুন

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Followed instructions but still cannot share screen in Google Meet

  • 2 উত্তরসমূহ
  • 1 এই সমস্যাটি আছে
  • 1 দেখুন
  • শেষ জবাব দ্বারা MK

more options

I was testing Google Meet with a friend. Both of us are using Win 10 (his is 18##, mine is 1909), both using Firefox 77.0.1. When he tried to Present his screen, Firefox presented the various popups and permission pages I've seen in the answers here and on on the web. When I try it, I keep getting blocked by Firefox.

I go into the Site Info > more info for Google Meet via the URL bar and changed the Share the Screen setting to Always Ask since Allow isn't an option.

When I click the Share Screen icon in the FF URL bar, I get the pop-down that includes an Allow checkbox but it is grayed out so it cannot be checked, and a message stating Firefox cannot allow permanent access to my screen. Which is fine, but it was giving me the exact same thing before I discovered the Meet URL > right click > Connection Secure > More Information > Permissions described above and pictured in one of the attached images showing I set it to Always Ask, which seems to be contrary to FF insistence that it won't allow me to permanently share.

When I once again try to Meet > Present > Window, I get the pop-up saying I have to give permission, thus throwing me back into the same frustrating loop.

Doubly frustrating is that my friend can share his screen going through the same steps I did, but he gets the pop-downs I see on the web that talk about "only share in trusted sites". I have never been presented with those pop-downs, even after closing all my tabs, clearing my cache and closing my browser for a bit.

I thought Meet would be easier for some of my less-than-computer-literate friends and family to use, but I need to be able to share my screen with them as well as they theirs with me.

Halp!

I was testing Google Meet with a friend. Both of us are using Win 10 (his is 18##, mine is 1909), both using Firefox 77.0.1. When he tried to Present his screen, Firefox presented the various popups and permission pages I've seen in the answers here and on on the web. When I try it, I keep getting blocked by Firefox. I go into the Site Info > more info for Google Meet via the URL bar and changed the Share the Screen setting to Always Ask since Allow isn't an option. When I click the Share Screen icon in the FF URL bar, I get the pop-down that includes an Allow checkbox but it is grayed out so it cannot be checked, and a message stating Firefox cannot allow permanent access to my screen. Which is fine, but it was giving me the exact same thing before I discovered the Meet URL > right click > Connection Secure > More Information > Permissions described above and pictured in one of the attached images showing I set it to Always Ask, which seems to be contrary to FF insistence that it won't allow me to permanently share. When I once again try to Meet > Present > Window, I get the pop-up saying I have to give permission, thus throwing me back into the same frustrating loop. Doubly frustrating is that my friend can share his screen going through the same steps I did, but he gets the pop-downs I see on the web that talk about "only share in trusted sites". I have never been presented with those pop-downs, even after closing all my tabs, clearing my cache and closing my browser for a bit. I thought Meet would be easier for some of my less-than-computer-literate friends and family to use, but I need to be able to share my screen with them as well as they theirs with me. Halp!
স্ক্রিনশটসমূহ সংযুক্ত হয়েছে

All Replies (2)

more options

Are you possibly using Private Browsing mode in case this feature doesn't work in PB mode ?

more options

Good question, cor-el! Alas, I am not/was not in private browsing mode when this occurred.