Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

CPU running at 100% and higher

  • 12 cavab
  • 8 have this problem
  • 45 views
  • Last reply by galfromaway

more options

Since I upgraded to Firefox 7.0 in the last month, my CPU has been running at 100% or higher off and on. I've turned all my extensions off (Adblock Plus, NoScript, Flashblock, Ghostery, Leechblock, WOT), and it's still doing it randomly. It gets to the point where my CPU is running incredibly hot, and I've started forcing the software to close before it can get too overheated.

Any help or insight would be greatly appreciated!!!

Since I upgraded to Firefox 7.0 in the last month, my CPU has been running at 100% or higher off and on. I've turned all my extensions off (Adblock Plus, NoScript, Flashblock, Ghostery, Leechblock, WOT), and it's still doing it randomly. It gets to the point where my CPU is running incredibly hot, and I've started forcing the software to close before it can get too overheated. Any help or insight would be greatly appreciated!!!

Chosen solution

Your Flash plugin is a bit older. You need to update it.

Adobe Flash Player 10.3.183.7 (2.94 MB)

Update All your Firefox Plugins

When Downloading Plugins Update setup files, Remove Checkmark from Downloading other Optional Softwares with your Plugins (e.g. Toolbars, McAfee, Google Chrome, etc.)

Clear Cookies & Cache

Clear the Network Cache

Check and tell if its working.

Read this answer in context 👍 0

All Replies (12)

more options
more options

Thanks, mha007. I went through those. It's not Flash, as I have Flashblock. I don't use Adobe Reader. I use NoScript. It's not one particular website. I've started using less tabs. But I have no clue about video cards or anything like that - I haven't added one, and don't tend to watch a lot of videos. And I'm not using Windows, so some of the info you've sent me links for doesn't apply.

Any other suggestions? :)

more options

Seçilmiş Həll

Your Flash plugin is a bit older. You need to update it.

Adobe Flash Player 10.3.183.7 (2.94 MB)

Update All your Firefox Plugins

When Downloading Plugins Update setup files, Remove Checkmark from Downloading other Optional Softwares with your Plugins (e.g. Toolbars, McAfee, Google Chrome, etc.)

Clear Cookies & Cache

Clear the Network Cache

Check and tell if its working.

Modified by Hasan

more options

Thanks for this. I did all that you outlined, and it was fine for a while, but over the past couple of days it's started getting bad again. I've done the above again, and hopefully that'll remedy things.

more options

Just Clear Cookies & Cache and Clear Network Cache as suggested in my previous reply.

more options

Thanks, mha007. That did seem to do it. I'll remember to do it more regularly. Much appreciated.

more options

You are welcome

Modified by Hasan

more options

"And I'm not using Windows, so some of the info you've sent me links for doesn't apply. "

The following info is sometimes helpful if you need to use another browser or machine because of problems on whatever your usual machine is.

Note kb links such as firefox consumes a lot of cpu resources should try to link according to the browser version, and sometimes even the language used, also the + buttons are in fact drop down menus and text relating to another OS & other Firefox versions is often available if you click them.

more options

John99: The + buttons are in fact drop down menus and text relating to another OS & other Firefox versions is often available if you click them.

Thanks man. Didn't knew that..

more options

Ok, I've managed to come to the realization that it's likely the add-ons I'm using that are increasing my CPU usage with Firefox. I've tried enabling and disabling different ones, and have been interested to find that most of them still result in Firefox running hot.

Is there a list of add-ons that cause issues like this? Is there a way to see when using Activity Monitor what's triggered Firefox?

Is there any other way to deal with them other than my forcing Firefox to shut down when it starts to run as high as 180%?

I do clear my cache and cookies regularly, but that only lasts a few days. And it seems having Gmail and Facebook open (together and individually) seem to be a common denominator as well, but it does happen with other sites as well.

more options
more options

Thank you, mha007. I hope you know how much your info is appreciated. :)

Going to look at these now.