Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox/Norton Safe Search. May not be a Firefox problem, but...

  • 8 cavab
  • 3 have this problem
  • 7 views
  • Last reply by gvgr4139

more options

Firefox browser, v123.0.1, 64-bit. windows 10 Pro, 22H2.

Hello, this may not be a problem with Firefox itself at all, but I'd like to try to understand what the cause of the problem I and others are having.

I have Norton 360 installed, in this Windows 10 computer and like to use Firefox for internet browsing, it has always served me well.

I also have Norton Safe Search integrated/add-on to Firefox. This puts a red, green, or gray check mark at the end of each link that comes up during a search and has always worked before.

Recently, I've noticed that such check marks do not appear at all when doing a search with Firefox, but they are present when I do searches with MS Edge.

I am searching for a solution here, and also in the Norton Community. There are others there who have stated they are having the same problem.

Has anyone here heard of this before, would you have any suggestion as to what may be causing the lack of the Norton Safe Search check marks in Firefox searches?

Any input/suggestions would be welcome.

Firefox browser, v123.0.1, 64-bit. windows 10 Pro, 22H2. Hello, this may not be a problem with Firefox itself at all, but I'd like to try to understand what the cause of the problem I and others are having. I have Norton 360 installed, in this Windows 10 computer and like to use Firefox for internet browsing, it has always served me well. I also have Norton Safe Search integrated/add-on to Firefox. This puts a red, green, or gray check mark at the end of each link that comes up during a search and has always worked before. Recently, I've noticed that such check marks do not appear at all when doing a search with Firefox, but they are present when I do searches with MS Edge. I am searching for a solution here, and also in the Norton Community. There are others there who have stated they are having the same problem. Has anyone here heard of this before, would you have any suggestion as to what may be causing the lack of the Norton Safe Search check marks in Firefox searches? Any input/suggestions would be welcome.

All Replies (8)

more options

Firefox has stricter rules about extensions changing the new tab page. You can install New Tab Override and set it to *search.norton.com* which has the green ticks.

Helpful?

more options

Thanks for your reply, zeroknight. However, the problem is that when doing an internet search using Norton Safe Search in Firefox, the Safe Search check marks at the end of the search results no longer appear, but they used to up until recently.

In my case, Norton Safe Search 'is' present in every Firefox page and tap that opens up, so it is present and active...

Helpful?

more options

No extension is required for the green ticks to appear on *search.norton.com* but do note that news results and ads do not show them. If you search for "firefox", you should see a green tick next to "Get Firefox browser" like in the attached screenshot.

Does it still happen in Troubleshoot Mode?

Helpful?

more options

Fine, I understand what you are indicating, will give it a try. Thanks

Helpful?

more options

Would it not be better for Firefox to change its rules so that everything worked a previouly. This issue is becoming a nuisance. Many people have the same problem. Please try to reinstate it as it was. Thank you

Helpful?

more options

I made the 'ticks' work in two machines that are running the same version of Windows and the same version of Norton 360 and Firefox.

What I did is as follows:

Downloaded Firefox installation file just to have it ready.

I uninstalled Firefox and shut down the computer. If Firefox asks you if you plan to reinstall it, say no.

Some may not know this, it makes a difference to the OS between shutting down the computer completely, or just restarting from Windows.

I then turned the computer back on and let it boot into Windows, and reinstalled Firefox and Safe Search and add-on from Norton and made a few searches. All the 'ticks' are there again.

I reset all Firefox settings my way, just as I had them before.

Firefox and the ticks in the search links are still working in both computer two days after the re-installation.

This is what worked for me...

Helpful?

more options

I have done what is stated above but it did not work for me.

Helpful?

more options

Sorry it did not work for you. Honestly, what may be causing this problem in intriguing, and though it seems to have been solved on my side, I still wish to understand what is going on.

Helpful?

Sual ver

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.