Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox keeps asking to update, I'm running version 26??

  • 14 ردًا
  • 7 have this problem
  • 3 views
  • آخر ردّ كتبه Starky

more options

I've downloaded Firefox Setup Stub 26.0 and installed three times, each time it restarts I see a message saying there is a newer version of Firefox available, when I click on the link it asks me to download the same file again??? I'm running with windows vista with Firefox as my default browser, hope you can help as it's getting quite annoying with the constant popup telling me to update, thanks, John.

I've downloaded Firefox Setup Stub 26.0 and installed three times, each time it restarts I see a message saying there is a newer version of Firefox available, when I click on the link it asks me to download the same file again??? I'm running with windows vista with Firefox as my default browser, hope you can help as it's getting quite annoying with the constant popup telling me to update, thanks, John.

الحل المُختار

In case my cross-reference was confusing, here's a direct link to the article with the steps to clear out the false information about your Firefox version: How to reset the default user agent on Firefox.

Read this answer in context 👍 1

All Replies (14)

more options

Download and save the full Firefox installer to the desktop and start the installation with a double-click on the desktop icon.

You can find the full version of the latest Firefox 26.0 release in all languages and for all Operating Systems here:

more options

Hello,

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

Maybe a addon is triggering that message.

(If you're not using it, switch to the Default theme.)

  • On Windows you can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac you can open Firefox 4.0+ in Safe Mode by holding the option key while starting Firefox.
  • On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

FirefoxSafeMode

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

more options

Maybe it's the user agent override? See: How to reset the default user agent on Firefox.

more options

Note that your System Details List shows that you have a user.js file in the profile folder to initialize some prefs on each start of Firefox.

The user.js file is only present if you or other software has created it, so normally it wouldn't be there. you can check its content with a plain text editor if you didn't create this file yourself.

The user.js file is read each time you start Firefox and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session.

See also:

more options

Thanks cor-el, that seems to have fixed it, although some websites, like virgin media still display a message saying I'm running on an older browser (when I'm not) ?? however job done, cheers, all the best for 2014, hope everyones having a good time.

more options

Hi Starky, if you visit this test page, do you see an up-to-date user agent?

https://jeffersonscher.com/res/jstest.php

For example, on Windows NT 32-bit you would expect:

Mozilla/5.0 (Windows NT 6.0; rv:26.0) Gecko/20100101 Firefox/26.0

more options

Note that you still need to reset prefs that were set via the user.js file to the default value.

You can rename or delete the prefs.js file and possible numbered prefs-##.js and user.js files to reset all prefs to the default value.


Clear the cache and cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > Cookies: "Show Cookies"
more options

Hi jscher, appears to be, this is what I have....Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 thanks.

more options

Hi Starky, to fix that, see the article I linked earlier in this post: https://support.mozilla.org/en-US/que.../981977#answer-517755].

more options

You can check the general.useragent prefs on the about:config page.

You can open the about:config page via the location bar like you open a website.
You can accept the warning and click "I'll be careful" to continue.

Search: general.useragent
If general.useragent prefs are bold (user set) then you can right-click that pref and choose Reset.
Especially reset the general.useragent.override pref.

See also:

more options

Waka_Wocka_Flame, tried the safe mode but was still the same on a couple of websites, saying I'm running an older version, so it cant be the add on that's causing it, thanks anyway bud.

more options

Did you manage to reset the user agent to Firefox/26.0?

more options

الحل المُختار

In case my cross-reference was confusing, here's a direct link to the article with the steps to clear out the false information about your Firefox version: How to reset the default user agent on Firefox.

more options

OK jscher, thanks, I had another look at this and went through the useragent list resetting, although they were different to the article and some were greyed out, thus not allowing me to reset, it now appears that this has the desired effect, I'm no longer running an older version of Firefox and I've also checked some of the websites that were playing up and everything appears hunky-dory, cheers buddy for taking the time to respond, I was sweatin a wee bit there thinking I might need to go back to IE (heaven forbid).