ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Site search will not work in Firefox but works with Chrome

  • 24 ردًا
  • 9 have this problem
  • آخر ردّ كتبه John99

more options

I run three websites. One is personal (www.rossolson.org) and two are for non-profit organizations (www.outpostministries.org and www.tccsa.tc). All have site search through Google, my own site is paid to be ad-free, the non profits are free and without adds because of their non profit status. For a while now, site search does not work with Firefox for the non profit sites but does for the paid site. Chrome and IE work fine. Is there a solution? Some setting to activate? Is this Google's doing?

All Replies (20)

more options

Are you getting a specific error message? blank results?

All 3 work for me:

  • On your personal site, I find a link to the Search page, and I get redirected to the Atomz site.
  • On TCCSA, I find a link to the Search page, and I get embedded results from Google Custom search.
  • On Outpost Ministries, I eventually find a search link on the Resources menu, and I get embedded results from Google Custom search.

Note: I was logged out of my Google account when testing.

In case this is a cache/cookies problem from Google, try this if you haven't already done so:

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Bypass Firefox's Cache

Use Ctrl+Shift+r to reload the page fresh from the server.

Alternately, you also can clear Firefox's cache completely using:

orange Firefox button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Alt+t (open the classic Tools menu) > Page Info > Security > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then go back and test your site search again. Any difference?

more options

That series of steps did not solve it. What is next? Thanks.


more options

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.

You can also check the cookie exceptions to make sure that you aren't blocking cookies.

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page.

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious and if you have a password or other data from that domain that you do not want to lose then make a note of those passwords and bookmarks.

You can't recover from this 'forget' unless you have a backup of the involved files.

It doesn't have any lasting effect, so if you revisit such a 'forgotten' website then data from that website will be saved once again.

more options

Hi Ross, "does not work" is not enough information. Are you getting a specific error message? blank results?

more options

What happens is nothing. The search box is unchanged, nothing appears, no error message. It looks like I never entered a search item.

more options

You can check the request and response headers with the Live Http Headers extension.

See also:

more options

I did Safe Firefox mode -- still does not work.

I found the options and allowed pop ups for the two sites in question and also allowed addons from them. Then I rebooted. Still nothing happens.

more options

Hi rossolson, you wrote:

What happens is nothing. The search box is unchanged, nothing appears, no error message. It looks like I never entered a search item.

Just to clarify:

(1) The Google script successfully creates the search box showing Google Custom Search in faded text (this should clear when you click in the box).

(2) You click in the box and... you are not able to type in it? or you are able to type in it but you can't submit the search? or you submit the search and the form blanks out without returning any results?

more options

I am able to type a search word in but on clicking it, nothing changes. No results. the word just stays there.

I also downloaded the https://addons.mozilla.org/firefox/addon/live-http-headers/ -- at first I wondered if it was not letting me install. So I allowed it in exceptions. But I'm not clear on what it does or what I do to use it.

more options

Instead of using the add-on in this case, since you are not getting anything back, try using the Web Console. You can open it by pressing Ctrl+Shift+k.

Then submit your search and see whether any URLs or errors appear in the console. You also can try the Network tool (last button on the black bar, then click the Search button again) to confirm that the request was sent and is in progress.

more options

Everything worked fine for me as well. Maybe test a new firefox profile before you start digging too deep and try this simple thing first?

Close Firefox, go to windows search bar and type firefox.exe -p and create a new profile and launch, see if still happens. You can always go back easily the same way. takes 1 minutes to do.

Best regards

more options

I downloaded and installed Firefox in another folder and called it firefox 2. It must have imported all the settings from the original and nothing is any different.

Since I can search with the other browsers and other people can search with firefox, it is something about my system ... but what?

There have been strange goings on since the beginning with this HP Phoenix envy running windows 8. Initially it would not install Microsoft Streets and Trips. Many other things were not in the places expected.

more options

OK, I tried the Ctl shift k after searching and got the attached. what does it mean?


more options

I tried signing into the computer as my wife, checked firefox and went to the web sites and searched successfully. So it is something about the profile.

I would like to go back to defaults for my "Firefox2" but keep all my extras on the original version. can I do that?

more options

If you use the Firefox reset, it will remove all add-ons and user settings. What you can do is to go to the Mozilla Add-ons Web Page and get these on your system;


This will save your add-ons in the event of trouble,
and help you easily put them back.


This will save add-on and user settings and can restore them.
more options

I backed up with FEBE and OPIE, Reset, tried search -- still the same, hit Ctrl Shift k and got the attached.

more options

Hi Ross, in the first screen shot, I see that the search request was submitted to Google and Firefox got a response. I can't see that in the second screen shot. You can click the CSS button to temporarily hide the style warnings to reduce the clutter.

However, after a reset, most of the factors which could be interfering with the request/response/render cycle would have been cleared.

After a reset, some extensions will be found by Firefox in the Windows Registry. Could you check what you have currently enabled? You can check on the Troubleshooting Information page. Either:

  • Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

The extensions list is the second table down on the page.

more options

"Question owner

I tried signing into the computer as my wife, checked firefox and went to the web sites and searched successfully. So it is something about the profile.

I would like to go back to defaults for my "Firefox2" but keep all my extras on the original version. can I do that? "

You stated that everything worked fine under your wife's Login.

We seem to be ignoring the obvious here.

Did you go to the start menu and in the search box type in firefox -p then create a new Firefox profile? I think this is a logical place to start since we already determined it is the profile as it works perfectly on your wifes login. Putting Firefox in a folder called Firefox 2 is not the same thing, and am unsure of what you mean by that.


I also recommend Mozbackup, this will back up your entire profile of what you choose, including setting, extensions, passwords and store it as a seperate file, and i can speak from experience it does work

Modified by Carm

more options

I created a new account, saved it in a separate folder and activated it. I found that the saved bookmarks in BOTH accounts were removed. I had backed them up in an HTML file and re installed them but I guess I can live with the problem. I can do site search using other browsers and using Firefox from my laptop. since these are two websites that I manage, I just wanted to be sure that site search was working.

It is apparently not a Firefox issue. It is something about this computer which has been quirky from the beginning. HP support suggests I reset but that would mean reinstalling many programs which were hard to install. Thanks.


more options

There is a possibility of recovering some or even all lost bookmarks. It takes some effort and it may depend on the value of the bookmarks whether you wish to attempt this.

Backup any profiles that you have used that still exist . Unfortunately if they are not in use by a current install of Firefox you will need to use the second more difficult method to find them.

  1. easy Back up and restore information in Firefox profiles to find them
  2. Digging around http://kb.mozillazine.org/Finding_the_profile_folder_on_Windows

If you find profiles they have important bookmark related files in them.

  1. 1
  2. 2