X
Tap here to go to the mobile version of the site.

منتدى الدعم

navigation not working properly

Posted

Firefox has difficulty navigating nested frame sets. I posted this problem in detail several days ago but have not received your response. Initial Frame set is overridden. Its suppose to place secondary frameset within the splash screen frame of the first. Result is that Navigation menus are lost. Please respond. This is a critical problem for me. Thank you

URL of affected sites

http://www.johncregar.com

User Agent

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_8; en-us) AppleWebKit/533.16 (KHTML, like Gecko) Version/5.0 Safari/533.16

Firefox has difficulty navigating nested frame sets. I posted this problem in detail several days ago but have not received your response. Initial Frame set is overridden. Its suppose to place secondary frameset within the splash screen frame of the first. Result is that Navigation menus are lost. Please respond. This is a critical problem for me. Thank you == URL of affected sites == http://www.johncregar.com == User Agent == Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_8; en-us) AppleWebKit/533.16 (KHTML, like Gecko) Version/5.0 Safari/533.16

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_8; en-us) AppleWebKit/533.16 (KHTML, like Gecko) Version/5.0 Safari/533.16

More Information

Firefox has difficulty navigating nested frame sets. I posted this problem in detail several days ago but have not received your response

cor-el
  • Top 10 Contributor
  • Moderator
17690 solutions 160039 answers

Helpful Reply

See http://www.w3.org/TR/REC-html40/present/frames.html#h-16.3

You need to specify the name of the frame and not the id <frameset rows="*" cols="186,1454" frameborder="no">

 <frame src="Menu-Port.html" frameborder="no" scrolling="auto" noresize="noresize" name="Menu Bar" />
 <frame src="SPLASH.html" frameborder="no" scrolling="auto" name="MAIN" />

</frameset> (/forum/1/738929)

See http://www.w3.org/TR/REC-html40/present/frames.html#h-16.3 You need to specify the <u>name</u> of the frame and not the ''id'' <code>&lt;frameset rows="*" cols="186,1454" frameborder="no"&gt; &lt;frame src="Menu-Port.html" frameborder="no" scrolling="auto" noresize="noresize" name="Menu Bar" /&gt; &lt;frame src="SPLASH.html" frameborder="no" scrolling="auto" name="MAIN" /&gt; &lt;/frameset&gt; </code> ([/forum/1/738929])