Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Prevent FireFox from executing a search for "unknown" domains

  • 5 replies
  • 2 have this problem
  • 22 views
  • آخر ردّ كتبه fritzmg

more options

Since one of the recent FireFox updates, the default action in the URL bar for "unknown" domains is always a search. As a web developer, this is extremely aggravating, since I can no longer type "foo.local" into the URL bar and confirm, in order to access http://foo.local/ (see also attached image). It will instead execute a search for "foo.local".

I have looked through the options of browser.urlbar in about:config, but so far I couldn't identify if any of these options would influence this new behaviour.

Attached screenshots

Chosen solution

Hi, I belive that it's fixed in version 78 (1, 2).

This pref for the "local" domain is browser.fixup.domainsuffixwhitelist.local = true.

Read this answer in context 👍 0

All Replies (5)

more options

Modified by TyDraniu

Helpful?

more options

Modified by TyDraniu

Helpful?

more options

Chosen Solution

Hi, I belive that it's fixed in version 78 (1, 2).

This pref for the "local" domain is browser.fixup.domainsuffixwhitelist.local = true.

Helpful?

more options

I see. I'll check again if it is fixed with the update tomorrow (assuming it will indeed be released tomorrow).

Helpful?

more options

This is indeed (sort of) fixed in FireFox 78(.0.1). However, it is only fixed for the following domains by default:

  • .example
  • .internal
  • .invalid
  • .local
  • .localhost
  • .test

You can add more subdomains via the already mentioned config key

 browser.fixup.domainsuffixwhitelist.foobar = true


However, it would also be helpful to be able to disable this feature entirely.

Modified by fritzmg

Helpful?

اطرح سؤالا

عليك الولوج إلى حسابك للردّ على المشاركات. من فضلك اطرح سؤالًا جديدًا لو لم يكن لديك حساب بعد.