Search Support

YouTube viewing

  • 3 replies
  • 1 has this problem
  • 4 views
  • آخر ردّ كتبه jscher2000

more options

What is going on with using YouTube on Firefox? All of a sudden, the last few days, I keep getting a yellow bar saying that there is a error with Script, Then I find out that the current Firefox does not use Java Script.

This is very annoying, I've and tired of getting this error message every time I open or close a YouTube video. I would prefer that I be able to watch YouTube on Firefox, but I will not watch it much longer if this is what I have to put up with.

I think that if you don't want to allow Java than you provide a platform that with run YouTube without issue. I've used Firefox for sense the early 90s and you are well know for making changes that don't provide a user friendly environment every now and again. If you can't provide a error free means of watching YouTube, I will be looking for a Browser that does. Even though I hate being tracked by Google. I am sure they track my us of YouTube but at least I don't have to put up with poor viewing or have a video interrupted because of Java Script not being used.

All Replies (3)

more options

Hi GlennT, what does the error say, exactly?

Firefox runs website JavaScript scripts by default, but sometimes they are ignored because of, for example:

  • the source server is on a block list used by Firefox's Enhanced Tracking Protection feature
  • an add-on blocks them because they are perceived as related to unwanted ads or a privacy threat

You could test in Firefox's Safe Mode as a general diagnostic. In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement on YouTube?

Helpful?

more options

It thank you for the reply, I don't understand any off it. I can't give you the exact wording as the warning does not stay long enough to copy or write down. I have managed to got to the link about the error but that is all confusing to me. This is the link https://support.mozilla.org/en-US/kb/warning-unresponsive-script#w_other-causes. Ans following it to the best of my ability it does not change. I am not sure what is causing it, I do know that It started a couple of days ago. I does say Dashlane has detected it or something like that. But if it's a Dashlane problem I would expect it to happen on Chrome as well and it does not. I have no idea what your asking me to do or how to go to safe mode in Firefox. I really hate it when tech savoy people think that everybody understand their canned answers. All I know is that I can't use Firefox to watch YouTube videos without the interruptions while going from one video to another in my playlists. It stops all actions while stopping one video and going to the next on my list. It is very annoying.

Helpful?

more options

Hi GlennT, if the message disappears quickly, it sounds like something is slower than it should be, but it isn't stuck in an infinite loop. I wonder why Dashlane is mentioned. Isn't that for filling login forms? Very odd.

For testing in Safe Mode, I tried to spell out the steps as specifically as I could. Where are you getting hung up:

jscher2000 said

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled
and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Helpful?

اطرح سؤالا

عليك الولوج إلى حسابك للردّ على المشاركات. من فضلك اطرح سؤالًا جديدًا لو لم يكن لديك حساب بعد.