Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

open link in new tab

  • 18 replies
  • 2 have this problem
  • 315 views
  • آخر ردّ كتبه okkehel

more options

I do not know how to make sure that firefox opens links in a new tab. In Preferences I checked the option 'always open in a new tab instead of a new window' but that does not work: links are always opened in the same tab but not in a new one. How to make that happen?

Chosen solution

Hello okkehel,

Would you try this please :

Type in the address bar about:config and press Enter (ignore the warning)

Type in the search bar and look for the preference :

browser.search.openintab and make sure its value is set to true.

Do the same for these preferences :

browser.urlbar.openintab and browser.tabs.loadBookmarksInTabs

If you had to change a value, then close and restart Firefox.

Any luck ?

Read this answer in context 👍 1

All Replies (18)

more options

You have to generally middle click to make links on a page open in a new tab. Also check browser.newtabpage.enabled in about:config is set to true

Helpful?

more options

Chosen Solution

Hello okkehel,

Would you try this please :

Type in the address bar about:config and press Enter (ignore the warning)

Type in the search bar and look for the preference :

browser.search.openintab and make sure its value is set to true.

Do the same for these preferences :

browser.urlbar.openintab and browser.tabs.loadBookmarksInTabs

If you had to change a value, then close and restart Firefox.

Any luck ?

Helpful?

more options

Did what you wrote, but it does not work. Everything is opened in the same tab.

Thanks anyway for your reaction.

Helpful?

more options

Setting the values of those preferences to true should work ....

You did of course close and restart Firefox after you changed a value .... (?)


What I always do when I want to open a link in a new tab is press the Ctrl key on my keyboard and then click on the link. Never fails ....

I don't use (have nor want) a mouse.


You could also give this add-on a try :

https://addons.mozilla.org/en-US/firefox/addon/open-link-with-new-tab/

Helpful?

more options

I am as amazed as you are. In closed and reopened ff, installed the add on. No result. Disabled addon GroupSpeed (it does somenthing with tabs). No effect. Everything is opened in the same tab. I can only think of one thing: it is a little bug in ff for osx (macOS Catalina).

Again, thanks; have to accept it I gues....

Helpful?

more options

okkehel said

I am as amazed as you are. In closed and reopened ff, installed the add on. No result. Disabled addon GroupSpeed (it does somenthing with tabs). No effect. Everything is opened in the same tab. I can only think of one thing: it is a little bug in ff for osx (macOS Catalina). Again, thanks; have to accept it I gues....

I noticed one exception: in the topbar there an item Extra and then: add-ons. Clicking on add-ons opens in a new tab.

Helpful?

more options

okkehel said

I noticed one exception: in the topbar there an item Extra and then: add-ons.

I must admit that I haven't a clue what you are referring to ..... :(

Would it be possible to provide a screenshot ?

The only thing I can think of is that you are talking about Preferences => Add-ons; that will always open in a new tab ....

Helpful?

more options

I am Dutch, so I think it is indeed Preferences. See screenshot...

Helpful?

more options

okkehel said

I am Dutch, so I think it is indeed Preferences. See screenshot...

Yes, and like I said : when you click on "Add-ons" it will always open in a new tab.

But fact remains that everything else that was suggested doesn't work for you, and that puzzles me ....

I'm hoping that someone else will see this and come to your rescue


(wat een toeval; ik ben de enige Nederlandse hier ..... )

Helpful?

more options

When you press Cmd and then click on the link : that doesn't work either ? (I said Ctrl earlier, because I'm on Windows and overlooked the fact that you're on Mac)

Helpful?

more options

What links is this about ?

Is this about links on web pages ?

The above posted suggestions are for opening bookmarks and search results.

For opening links on web pages there is a setting in "Options/Preferences -> General", but that setting only applies to link that specify a target window and you can divert such links to a tab. For other links you need to middle-click with the mouse wheel like posted above or on Mac hold the Command key and left-click the link.

You can look at the browser.link.open_newwindow prefs on the about:config page.

  • browser.link.open_newwindow (3)

1:current tab; 2:new window; 3:new tab;

  • browser.link.open_newwindow.restriction (0)

0:divert always; 1:divert never; 2:divert only if not specifying dimensions

Helpful?

more options

McCoy said

When you press Cmd and then click on the link : that doesn't work either ? (I said Ctrl earlier, because I'm on Windows and overlooked the fact that you're on Mac)

Yes, that works

cor-el said

What links is this about ? Is this about links on web pages ? The above posted suggestions are for opening bookmarks and search results. For opening links on web pages there is a setting in "Options/Preferences -> General", but that setting only applies to link that specify a target window and you can divert such links to a tab. For other links you need to middle-click with the mouse wheel like posted above or on Mac hold the Command key and left-click the link. You can look at the browser.link.open_newwindow prefs on the about:config page.
  • browser.link.open_newwindow (3)
1:current tab; 2:new window; 3:new tab;
  • browser.link.open_newwindow.restriction (0)
0:divert always; 1:divert never; 2:divert only if not specifying dimensions

All kind of links: bookmarks, searchresults in google, search in urlbox, llinks in emails...Everything is opened in the same tab except when I press command.

Helpful?

more options

If "Cmd click link" works : well, at least that is something, but the other settings not working, puzzles me.

Let's see what cor-el comes up with .....

Helpful?

more options

For opening a bookmark in a new tab, setting this pref to true on the about:config page should work.

  • browser.tabs.loadBookmarksInTabs = true

For the search bar on the Navigation toolbar you can set this pref to true on the about:config page.

  • browser.search.openintab = true

Whether addresses and search results typed into the address bar should be opened in new tabs by default.

  • browser.urlbar.openintab = true

For Google search results in a new tab, you can set that in the Google search preferences.

You can override how external links are opened via the browser.link.open_newwindow.override.external pref. If this pref has the default value -1 then browser.link.open_newwindow is used. The meaning of the value of browser.link.open_newwindow.override.external is the same as of browser.link.open_newwindow

Helpful?

more options

@ cor-el :

Re the first three prefs you mentioned : see my first post (doesn't work ....)

Helpful?

more options

Bookmarks are now opened in a new tab. Webaddress in addressbar also.

I am satisfied. Thanks for the support. Problem solved

Helpful?

more options

okkehel said

Bookmarks are now opened in a new tab. Webaddress in addressbar also. I am satisfied. Thanks for the support. Problem solved

Just curious :

What exactly is it that solved the problem ?

The only pref that you hadn't tried yet is :

browser.link.open_newwindow.override.external

Is that what did the trick ?

Helpful?

more options

No, that one I did not apply; I think the three 'about:config' entry's worked after all. I changed a setting in the add-on Group Speed Dial, restarted and now new tabs are opened. In that add-on is a preference possible about opening in a new tab or not. I thing that caused the problem but I am not sure.

Again, thanks for the support.

Helpful?

اطرح سؤالا

عليك الولوج إلى حسابك للردّ على المشاركات. من فضلك اطرح سؤالًا جديدًا لو لم يكن لديك حساب بعد.