Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Previous fix to eliminate unwanted question marks no longer works.

  • 19 replies
  • 1 has this problem
  • 74 views
  • آخر ردّ كتبه Franknca

more options

The solution below no longer works. My current version of Firefox is 64.0.2

When did this problem start for you?

On Mac, Firefox 56 ratcheted up the security sandbox, limiting which files pages can use on your system. This apparently prevents Firefox from using font files in a "suitcase" or "Adobe Type 1" format. The developers are aware of this and some fixes were made in Firefox 57, but they might have missed some font types or unexpected font file locations.

To see whether this is the problem, and as a temporary workaround, you can reduce the sandbox security level back to what it was in Firefox 52-55 as follows:

(1) In a new tab, type or paste about:config in the address bar and press Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste sand and pause while the list is filtered

(3) Double-click the security.sandbox.content.level preference and change the value from 3 to 1 and click OK

That change won't take effect until the next time you quit and restart Firefox

All Replies (19)

more options

Did you try to disable the sandbox altogether?

  • security.sandbox.content.level = 0

What font is this about that Firefox changes to a last resort font and where is it stored?

You can check the font used for selected text in the Font tab in the right pane of the Inspector.

Note that this is not about the font-faily CSS rule, but about the font that Firefox actually uses as shown in the Font tab.

more options

Thanks for the "zero" suggestion. I will have to wait a few hours to give it a try, but I will let you know the result either way. As for the other, I am not a developer and I really don't want to spend a lot of time experimenting - especially in places I'm not familiar with. Whatever the fonts, they are undoubtedly common ones - and I am not even sure that any given font is always being relpaced. I do have a few screen captures. If I feel ambitious - and if the "zero" idea doesn't work out, maybe I will try to check the fonts. Thanks again! (And stay tuned later.)

more options

This appears to have worked, so thanks, again.

I suppose if he question marks creep back into view, I will just have to change the setting to ............. "11" ................. ; - )

That's a little nonDeveloper humor.

Thx.

Well, I may have spoken too soon. This morning, I downloaded Firefox 65.0. When I opened it, nothing displayed below the Bookmarks Toolbar -- and no button or icon worked. The text in the tab for the empty window said "Private Browsing." It seems like I could access my Preferences and I took a quick look but didn't see anything to change. I used the "about:config"/"sand" steps to resotre the number to 1. I shut down, reopened and got content again - but with the same display error of question marks in several places (I didn't surf around much). I decided to change it to zero again to see if content would display -- since I wouldn't be opening it for the first time in a new version -- but once again got no content displaying. This time, I didn't seem able to open my preferences. I have restored the setting to 3, rather than 1, just to see what that gets me - but I know for sure it gets me some question marks. You would think that Firefox would have solved this problem themselves by now - rather than keep squabbling with Adobe, if that's what it amounts to. I am really close to moving all my boomakrs to Chrome and getting used to that for a browser - whether I like it or not. Any ideas? Thanks in advance ... Rob

Modified by robkuhnjr

more options

I too have this issue. Changing it to 0 does not help.

Changing it to 1 did the trick before. Now since I upgraded to version 65.0.1 it doesn't work anymore.

I just implemented Firefox policies for enterprise and firefox is the default browser in our company. I guess I'll see how I can pimp chrome to become the standard. I can't have 1000+ users calling helpdesk because they can't use their browser anymore.

more options

I don't think it occurred to me to circle back to "1" ... or maybe I did.

I have migrated the bookmarks that seem to have the biggest problems with this to Chrome. But I do not like the intrusiveness of Chrome. I am not into having my work and personal files "synced"

I understand that many people find this helpful - and it unarguably is helpful. I just find the balance with invasion of privacy (increasingly hard to avoid, I also realize) to be extremely annoying.

I hope there is a way for you to avoid such intrusion if you wind up making Chrome the default.

I dont know what Mozilla is thinking -- apparently not much. I just selected "Very dissatisfied" in the survey they pushed me. Apparently that short-circuited two minutes to two seconds.

more options

@ arnokenis

You can check in the Font tab in the Inspector to see what font Firefox would want to use and where this font it stored.

You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected.

You can check the font used for selected text in the Font tab in the right pane of the Inspector.

Note that this is not about the font-family CSS rule, but about the font that Firefox actually uses as shown in the Font tab.

more options

Thanks arnokenis ... sincerely ... but that is a bridge too far for me. I am not a developer; I don't want to mess around in developer pages.

I had to check to see if I had changed their primary default for Font -- and I did not.

As far as I am concerned, this is a problem with Mozilla's code and it's their responsibility to get it under control. I have no interest in taking on any additional admin tasks related to all this convenient, time-saving technology.

I don't like moving bookmarks to Chrome (I think I already said that), but if that is the path of least resistance, I will take it [ at least until it pisses me off more than this ].

But thanks again, sincerely, for your advice!

Rob

more options

Hey Rob.

I understand, it was not me asking you to do the developer things.

I have done the same as you. I created a settings profile for chrome (where you can enable the transfer of bookmarks from firefox and disable all the intrusive features too). And I'm rolling out new latest chrome as we speak.

Too bad, but I have no choice. A lot of my users are impacted and I can't afford any downtime.

Good Luck! Arno

more options

The sandbox problem shouldn't affect Macs where Firefox simply uses the built-in fonts. What third party font managers do you guys use on your Macs?

more options

Well, that makes sense. I don't experience this issue on my Mac at home. In the office, we use Universal Type Client -- in conjunction with Adobe Creative Cloud apps.

The company seems to have enough trouble wrangling the fonts - and preventing Designers from using variations we don't have to pay for. This has been a problem for a long time. "Recently," following the rollout of Woodwing, there has been an effort to get the font usage under control.

Probably the best I can do is raise this as a general issue with the helpdesk and see if they want to explore it. Some folks have experienced the same issue in their MS Office Outlook app. So maybe the helpdesk will research it.

Thanks!

more options

Hi Rob, if there is a standard path for Universal Type Client that should be whitelisted to avoid sandbox problems, you can submit it through Bugzilla. However, it could take a couple versions before that is released.

https://bugzilla.mozilla.org/

Possibly Adobe has a note on it somewhere?

more options

Hi ... Thanks, very much, but that's getting beyond the level of effort I want to expend just to have a font display properly. A few particular barriers include: I don't know how to determine a "standard path" for Universal Type Client. A search for "Adobe - Firefox - Universal Type Client" brought up a handful of problems, but not mine. I don't know what "whitelisting" is. I'm afraid I could do all you suggest but then find out the problem is too local to my setup for Firefox to fix universally - or provide some specific fix for me. My feeling is that since you have been able to figure this out from my series of comments, Mozilla should already be aware that there are issues with these interactions - and be attempting to correct them. I'm just not sure -- repeating myself now -- that they can offer some universal solution. But thanks again! for shedding more light on why I've been seeing this problem. Rob

more options

We also use universal type client, so our issues seem to be identical.

@jscher2000 How can I determine the standard path of Universal Type Client?

more options

FYI, everyone ... my desktop iMac had a minor stroke this morning ... or at least the MS Office suite did. I saw the question marks in a couple of Excel files. But when another Excel file that I open every day earned me an error dialog, I decided to shut down, pause a minute, and start up again. That cured the Excel issues - but the font display problem is definitely not restricted to Firefox. I got a couple of screen shots of the Excel errors and so I can start a helpdesk ticket. Might as well, and see what their motivation is to troubleshoot and maybe correct this. Thanks, all ... and keep talking. Rob

more options
more options

I have tried to follow this but I am using a PC not a Mac and people are now telling me that my replies have ??? added after sentences. I can not figure out how to fix this as I don't know if it's a bug from a recent update or what. I can go into tools and such but don't see anything that I can change. Is there a simple solution?

more options

Franknca said

I have tried to follow this but I am using a PC not a Mac and people are now telling me that my replies have ??? added after sentences. I can not figure out how to fix this as I don't know if it's a bug from a recent update or what. I can go into tools and such but don't see anything that I can change. Is there a simple solution?

Hi Franknca, are you composing those messages on a website in Firefox, or in the Thunderbird email program? Since your situation is different from the issue in this thread, I suggest starting a new question using the most applicable link:

On either page, scroll down past article links to continue with the form.

more options

Composing in T-bird. I'll post on another forum as you suggest.