ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Installed FF61 and now GMail won't load.

  • 5 ردود
  • 2 have this problem
  • 4642 views
  • آخر ردّ كتبه Shadow110

more options

FF just restarted and installed version 61.0. Now I can't get to Gmail. I get an error stating:

Secure Connection Failed

An error occurred during a connection to mail.google.com. SSL received a record that exceeded the maximum permissible length. Error code: SSL_ERROR_RX_RECORD_TOO_LONG

   The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
   Please contact the website owners to inform them of this problem.

Gmail works just fine in Chrome and IE. Anyone else having this problem?

Attached screenshots

الحل المُختار

In recent days, this error code has surfaced much more frequently than in the past, and seems to have a new cause:

"SSL_ERROR_RX_RECORD_TOO_LONG" is occurring when Firefox and a website try to negotiate a connection using the latest TLS protocol (version 1.3) and a "man-in-the-middle" -- typically Avast Web Shield or AVG Web Shield -- somehow messes it up.

Until this is sorted out, I think your two workarounds are either:

(1) Remove the man in the middle (disable Web Shield for secure connections).

See the Avast section of: How to troubleshoot security error codes on secure websites.

(2) Disable TLS 1.3 in Firefox so it connects using an older protocol. To do that:

(A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(B) In the search box above the list, type or paste TLS and pause while the list is filtered

(C) Double-click the security.tls.version.max preference to display a dialog where you can change the value from 4 to 3 (this corresponds to TLS 1.2) and then click OK

Read this answer in context 👍 1

All Replies (5)

more options

Hi, try quick fix  : Certain Firefox problems can be solved by performing a Clean reinstall. This means you remove your Firefox program files and then reinstall Firefox. This process does not remove your Firefox profile data (such as bookmarks and passwords), since that information is stored in a different location.

To do a clean reinstall of Firefox, please follow these steps: Note: You might want to print these steps or view them in another browser.

  1. Download the latest Desktop version of Firefox from this page) and save the setup file to your computer.
  2. After the download finishes, close all Firefox windows (or open the Firefox menu New Fx Menu and click the close button Close 29).
  3. Delete the Firefox installation folder, which is located in one of these locations, by default:
    • Windows:
      • C:\Program Files\Mozilla Firefox
      • C:\Program Files (x86)\Mozilla Firefox
    • Mac: Delete Firefox from the Applications folder.
    • Linux: If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it - see Install Firefox on Linux. If you downloaded and installed the binary package from the Firefox download page, simply remove the folder firefox in your home directory.
  4. Now, go ahead and reinstall Firefox:
    1. Double-click the downloaded installation file and go through the steps of the installation wizard.
    2. Once the wizard is finished, choose to directly open Firefox after clicking the Finish button.

More information about reinstalling Firefox can be found here.

WARNING: Do not use a third party uninstaller as part of this process. Doing so could permanently delete your Firefox profile data, including but not limited to, extensions, cache, cookies, bookmarks, personal settings and saved passwords. These cannot be easily recovered unless they have been backed up to an external device! See Back up and restore information in Firefox profiles.

Please report back to say if this helped you!

Thank you.

more options

Well, it sometimes works and sometimes doesn't. Same with just searching on Google itself. Sometimes I can search Google and get results, sometimes I get the error about the SSL being too long.

Very strange.

more options

الحل المُختار

In recent days, this error code has surfaced much more frequently than in the past, and seems to have a new cause:

"SSL_ERROR_RX_RECORD_TOO_LONG" is occurring when Firefox and a website try to negotiate a connection using the latest TLS protocol (version 1.3) and a "man-in-the-middle" -- typically Avast Web Shield or AVG Web Shield -- somehow messes it up.

Until this is sorted out, I think your two workarounds are either:

(1) Remove the man in the middle (disable Web Shield for secure connections).

See the Avast section of: How to troubleshoot security error codes on secure websites.

(2) Disable TLS 1.3 in Firefox so it connects using an older protocol. To do that:

(A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(B) In the search box above the list, type or paste TLS and pause while the list is filtered

(C) Double-click the security.tls.version.max preference to display a dialog where you can change the value from 4 to 3 (this corresponds to TLS 1.2) and then click OK

more options

Thanks. I do have Avast installed so I'll go turn that off and see if it gets better.

more options