Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Fire fox does not translate font on various site and just gives me "?" in squares. it is hard to read "?" in squares

  • 4 replies
  • 1 has this problem
  • 1 view
  • آخر ردّ كتبه cor-el

more options

On various sites - I.E. news, ordering items etc - some fonts are readable and other fonts show up as ? in a box

All Replies (4)

more options

Type about:preferences#content<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own.

[v56+] Type about:preferences#general<enter> in the address bar. Under fonts and colors, press the Advanced button. Scroll to the bottom, turn on Allow Web Sites To Choose Their Own.

Fonts Information - Detected via Flash http://browserspy.dk/fonts-flash.php?detail=1


Firefox 52+ has changed from Cairo to Skia for canvas/content rendering. When Direct2D on Windows isn't used, Skia is used for content rendering

Would you please try this : Type in the address bar about:config (press Enter) (promise to be careful if asked)

Type in the search bar gfx.canvas and look for the preference: gfx.canvas.azure.backends and set its value to direct2d1.1,cairo,skia

Type in the search bar gfx.content and look for the preference: gfx.content.azure.backends and set its value to direct2d1.1,cairo,skia

Then close and restart Firefox in order for the change to take effect. If this doesn't make a difference, change the values back to their default by clicking 'Reset'.

more options

no change in my problem - button was already checked for "allow web site to choose their own"

more options

Please provide public link(s) (no password) that we can check out. No Personal Information Please !

more options

You can check for sandbox security related issues.

You can set this pref to 2 or 1 on the about:config page to lower the sandbox security setting.

  • security.sandbox.content.level = 1
  • close and restart Firefox to make the change effective.

If '1' still doesn't have effect then try '0' to disable the sandbox.

If this didn't work then undo/reverse the change and reset the pref via the right-click context menu to the default value.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.