Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox keeps crashing when I try to watch videos

  • 9 replies
  • 5 have this problem
  • 2402 views
  • آخر ردّ كتبه FredMcD

more options

Chosen solution

Since refreshing firefox did not help, I uninstalled and reinstalled firefox before I disabled the Kaspersky add-on extension. That seems to have worked. So far no more crashes when watching a video on youtube or netflix (I don't watch videos on that many sites). I will disable the Kaspersky add-on extension too. It had been automatically disabled by firefox until just recently. Thank you for your help.

Read this answer in context 👍 0

All Replies (9)

more options

Refreshing firefox has not helped.

more options

Youtube currently uses the HTML5 player.


bp-6eadd5e5-6ac4-48b1-bfc4-f0e2b2160423 bp-60e48ed9-908d-413f-90ac-9e6a02160423

Signature: mozilla::MediaSourceResource::GetCurrentPrincipal

inproc_agent.dll = Kaspersky Inproc Agent


Disable/remove Kaspersky.

more options

FredMcD said

Youtube currently uses the HTML5 player.

bp-6eadd5e5-6ac4-48b1-bfc4-f0e2b2160423 bp-60e48ed9-908d-413f-90ac-9e6a02160423

Signature: mozilla::MediaSourceResource::GetCurrentPrincipal

inproc_agent.dll = Kaspersky Inproc Agent


Disable/remove Kaspersky.

more options

Are you talking about the Kapersky add-on in the extensions?

more options

Try to disable the plugin first. If the problem continues, disable the main.

more options

FredMcD said

Try to disable the plugin first. If the problem continues, disable the main.

Do you know how to disable the main one? Thanks for your help. I appreciate it a lot.

more options

Sorry, I don't know Kaspersky.

more options

Chosen Solution

Since refreshing firefox did not help, I uninstalled and reinstalled firefox before I disabled the Kaspersky add-on extension. That seems to have worked. So far no more crashes when watching a video on youtube or netflix (I don't watch videos on that many sites). I will disable the Kaspersky add-on extension too. It had been automatically disabled by firefox until just recently. Thank you for your help.

more options

Hello,

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily.

Thank you for contacting Mozilla Support.