Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Stop Firefox reloading webpages when hitting back button

  • 10 replies
  • 13 have this problem
  • 199 views
  • آخر ردّ كتبه finitarry

more options

Is there any way to make hitting the back button not reload pages? It's become a bit of annoyance to me within the past few days because it sorta messed with my flow.

For example, let's say I'm looking at a phpBB forum. There's a unread posts button next to each topic. I click on the one next to a topic, this topic has 3 pages. The last post I read was halfway down the first page, it takes me to it (and adds "&view=unread#unread" to the URL). I finish reading the page, and move on to page 2. Partway down page two, I decide to go back to page 1 to re-read something that got quoted, and click the back button. But because of what seems like a recent change, Firefox attempts to reload the page instead of its old functionality... and thanks to the unread bit at the end of the URL, phpBB serves up page *3*. Now instead of going back, I've gone forward.

All Replies (10)

more options

In about:config, you can set this:

  • browser.cache.check_doc_frequency - set to 2 ( means never)
more options

Unfortunately changing that setting didn't do... anything, as far as I can tell. Firefox still keeps reloading pages when I hit the back button.

more options

What that setting does is make the browser reload from the cache, and never check the cache versus the online version. It works for me. The page is fetched from the cache and remains the same. I have to force a reload from the server by holding down the Shift key while clicking the reload button.

more options

browser.cache.check_doc_frequency user set integer 2

That's literally how it looks in my about:config and it made no difference.

more options

A way to avoid this is to open the links in a new tab with a middle-click and close the tab(s) to go back. That also avoids a large tab back history that clutter the sessionstore.js file.

more options

Uh, no? That doesn't help at all. It doesn't matter if I open the link in a new tab or not; if I'm on a forum it doesn't matter if hitting the "unread posts" button normally or opening in a new tab; "back" still reloads and goes forward.

more options

This is irritating. This should not be necessary. In every previous version, clicking the back arrow re-displays the page from cache; clicking the reload button reloads the page. The back button has essentially become a reload button. It's just wrong. and it fouls up my work-flow. Also, browser.cache.check_doc_frequency user set integer 2 did nothing to alleviate the issue.

Modified by mberner13

more options

You can try to disable automatic cache management.

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content
more options

Thanks. I already tried that to no effect. Next I'm goin g to try to set browser.cache.check_doc_frequency = 0 and see if that has any effect.

more options

This page gives more information about the settings: