ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

want to stop multiple spam windows from opening when I click on a link

  • 7 ردود
  • 5 have this problem
  • 9752 views
  • آخر ردّ كتبه trezzsc

more options

All of a sudden when I click on a link all sorts of spam windows open up. I have "Pop-Up" windows set to off....but they still open...also all of a sudden pages on line will have tons of words highlighted as hough they are links.... and when I click on them thinking it is a link it is another annoying pop up window. I have checked my "plug ins" and "add ons" and there is nothing there that I can find. I am using Windows 7 and this problem just began this week. I ran a McAfee scan and found no virus......can you help???

الحل المُختار

Those files are not supposed to be removed. Most likely user.js (Thanks for the heads-up jscher2000 about the hidden file extensions. A bonehead move by Microsoft) had some content in it that made all those windows pop up. The user.js file isn't there by default unless you made it so it's safe to erase it.

As for the .json files, those are needed by Firefox. More information about files in the Profile Folder can be viewed by using the link below

Read this answer in context 👍 1

All Replies (7)

more options

Note that you have a user.js file active in Firefox. The user.js file is only present if you or other software has created this file and normally it wouldn't be there.

You can delete a possible user.js file and numbered prefs-##.js files and delete the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in the current Firefox release. You can get to the profile folder below:

  • Help > Troubleshooting Information > Profile Directory > Show Folder

or

  • Go to about:support and click Show Folder next to Profile Directory.

If deleting those files doesn't help, Can you try to start Firefox in Safe Mode to see if Firefox works properly with no error? You can start Firefox in Safe Mode below:

  • Windows/Mac: Go to Help > Restart with add-ons disabled
  • Linux: Run firefox -safe-mode in the Terminal/Konsole

If Firefox opens up fine with no problems, it's probably one of your extensions that's causing the issue. You can re-enable your add-ons one by one until you find the one that causes the issue upon being re-enabled.

more options

I did not have a file named "user.js" but I have other"js" files....I deleted the pref.js files ....should I delete the following:

addons.json downloads.json extensions.json search.json sessionCheckpoints.json signedinuser.json times.json

thank you Chris Trezza

more options

Really? It's not there? Huh, that's odd... Your System Details show that there is one. Is this the same Firefox installation that's having problems or did you post it from another computer with Firefox installed?


Oh...I see what's happening here. You've been infected with Trovi adware junk. Here's an indication from your System Details


You should always pay attention when installing software because often, a software installer includes optional installs, such as this adware. Be very careful what you agree to install.
Adware gets on your computer after you have installed a freeware software (video recording/streaming, download-managers or PDF creators) that had bundled into their installation this browser hijacker.

You can use the below steps to revert back to adware-less Firefox.


1) Reset Prefs

  • Navigate to about:config in your Address Bar
  • Press the "I'll be careful, I promise!" button to proceed
  • Search for trovi and reset all prefs that pull up by right clicking > Reset
  • Also search for conduit and reset all prefs to be sure it's gone.

2) Remove any programs that you don't recognize or remember installing from your Control Panel (Start > Control Panel > Uninstall a Program)


3) Remove any extensions that you don't recognize or remember installing from Firefox.

  • Firefox 29 and above:(Press the menu button ( new fx menu > Add-ons > Extensions)
  • Firefox 28 and below:(Go to the orange Firefox button > Add-ons > Extensions)

4) Download ADW Cleaner to wipe out any remnants of the adware.

more options

Probably the reason you see .json files and not .js files is the annoying default setting of Windows to hide "known" file extensions. To work with file names accurately, I suggest turning off that setting. This article has the steps:

http://windows.microsoft.com/en-us/windows/show-hide-file-name-extensions

more options

Thank you....I wil do that next....so far the ones I have deleted had made things much better!....but should I delete those .json extensions listed above?

more options

الحل المُختار

Those files are not supposed to be removed. Most likely user.js (Thanks for the heads-up jscher2000 about the hidden file extensions. A bonehead move by Microsoft) had some content in it that made all those windows pop up. The user.js file isn't there by default unless you made it so it's safe to erase it.

As for the .json files, those are needed by Firefox. More information about files in the Profile Folder can be viewed by using the link below

more options

thanks so much......so far so good!