Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How do I get rid of title bar?

  • 7 uphendule
  • 5 zinale nkinga
  • 41003 views
  • Igcine ukuphendulwa ngu DrHow

more options

When I installed Firefox on my new Windows 8 computer, I got a style in which there is no title bar. The tabs are up there with an orange Firefox button at the left. It provides access to the menu items. I like that. However, I wanted the function of my profile on a Windows 7 machine. (Lots of stuff in there.) When I installed that, it put me back in a situation where there is a title bar unnecessarily wasting some vertical screen space. In that Windows 7 profile, I was using the Tiny Menu addon to compress the menu items onto a single button. It is on a line with the Location bar and the search bar. The tabs are below. I cannot figure out what to tweak in the profile from my Windows 7 to get to the appearance I like in the Windows 8 install.

I tried the advice here: http://www.squidoo.com/hide-firefox-title-bar I don't see any Tabs on Top setting, and browser.tabs.drawInTitlebar is already set to true. When I disable the Menu toolbar, the title bar goes away and the tabs are up there with the orange Firefox button; however, I lose the Location bar and the search bar altogether.

There's got to be a way to fix this. Any help would be appreciated.

Isisombululo esikhethiwe

Does the Navigation Toolbar has a checkmark if you right-click empty space on the Tab bar?

Does it has any effect if you open a new window?

You can check for problems caused by a corrupted localstore.rdf file.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (7)

more options
  1. Disable or remove Tiny Menu and all other extensions you may have that tamper with the menu bar or other toolbars. Be sure to restart Firefox when prompted.
  2. Right-click an empty area of the tab bar and choose Customize.
  3. Click the Restore Default Set button.
  4. Click the Done button.
  5. Right-click an empty area of the tab bar and make sure "Menu Bar" is not checked.

more options

Go to the Mozilla Add-ons Web Page (There’s a lot of good stuff here). There are many great add-ons that can do that and more. For example; Hide Add-on-Bar-Close-Button, None-button Remove new Firefox menu button leaving only the menu arrow, Tabs Always In Titlebar Move tabs into the titlebar in a normal (restored) window. Vertical Toolbar Adds a vertical toolbar at the edge of the window.


and many many more.

more options

Regarding disabling Tiny Menu, I did test with that disabled and several other addons (Tab Mix Plus for one) that I thought might interfere. No joy! I should have mentioned that. Sorry.

more options

Regarding additional addons, that does not make a whole lot of sense. If the Location Bar and search Bar are disappearing, something is wrong with my configuration. I am trying to find out what that is so I can fix it.

more options

Something very weird is going on. I achieved a brief success as follows:

Not sure exactly what did it. With Task Bar Plus, Stylish, All-in-One Sidebar, and the bookmarks toolbar disabled, I did do that reset to defaults for the toolbar. I had skipped that earlier because I did not see how it was going to affect the tab bar and my toolbar configuration (with All-in-one Side Bar) is fairly complicated. However, I was getting desperate. It still did not solve the problem directly. However, when I enabled the Navigation Bar, success! The odd thing is that I had fiddled with enabling the Navigation bar on multiple previous occasions with no luck; so I am still not sure exactly what happened. I thought the problem was solved. But it was not:

Then I started experimenting to figure out what had been causing it. I enabled all those things (except the bookmarks bar). It stopped working. I disabled Tab Mix Plus, and I got a brief success at the first instant when I enabled the Navigation bar. Then I restarted Firefox, and it did not work then or after any subsequent restart. I have gone so far as to restart in safe mode with all addons disabled. It still does not work right. I go back to the profile from the Windows 8 install, and all is well again.

What is going on? I may have to give up and further develop the profile from Windows 8 to come closer to the function I had in Windows 7; but I dread that process.

Okulungisiwe ngu DrHow

more options

Isisombululo Esikhethiwe

Does the Navigation Toolbar has a checkmark if you right-click empty space on the Tab bar?

Does it has any effect if you open a new window?

You can check for problems caused by a corrupted localstore.rdf file.

more options

Deleting localstore.rdf fixed it.