Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Youtube videos stop at 14 seconds?

  • 3 uphendule
  • 75 zinale nkinga
  • Igcine ukuphendulwa ngu donxepe

more options

Hi, whenever I try to play a youtube video in Firefox, it plays fine then just freezes at 14 seconds. This only happens in Firefox. I have the latest Flash Player.

All Replies (3)

more options


Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Once you get the pop-up, just select "'Start in Safe Mode"

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

more options

I just bought a brand new MacBook Pro Retina today. Installed Firefox 25.0 right away, without any add-ons, and this same pause on youtube at 14 seconds is happening...what gives?

Okulungisiwe ngu ericd2

more options

I think I've found the answer, at least it worked for me. Just go to Options > Advanced > General , and in the second section (could be "Navigation", I'm using firefox in another language so I don´t know if it is the same in english) uncheck "Use Hardware Acceleration when available". Videos still play smoothly and I haven't seen any other impact on firefox whatsoever.