Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox v19.02 keeps asking me to Choose User Profile each startup, and forgets the prior User Profile

  • 7 uphendule
  • 5 zinale nkinga
  • 914 views
  • Igcine ukuphendulwa ngu ckielstra

more options

Been using Firefox for years, just started having issues with it not being able to keep my bookmarks. Tried the entire help section for this issue, but it did not fix it. So I uninstalled and reinstalled v19.0.2.

Now each time I open firefox it asks me to Choose User Profile and none of the earlier profiles are in the selection area. So I create a new profile. When I close Firefox and open Firefox again, whether or not I restart my computer, the Choose User Profile box comes up again. But the profiles are in the folder location "profiles". Any suggestions?

All Replies (7)

more options

Hello!

Thanks for reaching out to Mozilla Support about your issue. We value and appreciate you as a user.

I can understand that you are frustrated and right now I am going to suggest a clean reinstall which should resolve this issue.

Certain Firefox problems can be solved by performing a Clean reinstall. This means you remove Firefox program files and then reinstall Firefox. Please follow these steps:

Note: You might want to print these steps or view them in another browser.

  1. Download the latest Desktop version of Firefox from http://www.mozilla.org and save the setup file to your computer.
  2. After the download finishes, close all Firefox windows (click Exit from the Firefox or File menu).
  3. Delete the Firefox installation folder, which is located in one of these locations, by default:
    • Windows:
      • C:\Program Files\Mozilla Firefox
      • C:\Program Files (x86)\Mozilla Firefox
    • Mac: Delete Firefox from the Applications folder.
    • Linux: If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it - see Install Firefox on Linux. If you downloaded and installed the binary package from the Firefox download page, simply remove the folder firefox in your home directory.
  4. Now, go ahead and reinstall Firefox:
    1. Double-click the downloaded installation file and go through the steps of the installation wizard.
    2. Once the wizard is finished, choose to directly open Firefox after clicking the Finish button.

Please report back to see if this helped you!

Best Regards,

feer56


Did you know that Mozilla Support is helped out by volunteers? Be part of SUMO! http://mzl.la/OJtpch


If any response posted satisfies you to be your solution, please mark it as your solution chosen.

more options

Try to delete the profiles.ini file to force Firefox to create a new profiles.ini file and a default profile.

Which security software (firewall, anti-virus) do you have?

more options

ESET NOD32 is my anti virus, been having it for about 1 year with no problems like this so far.

Okulungisiwe ngu Userprofile

more options

I follow these instructions and there is no profile.ini file in this location. In fact there are no files here, not even hidden files.

%APPDATA%\Mozilla\Firefox

more options

I performed a clean install, this did not change the issue.

Firefox still starts up like the first time each time it starts. Wanting me to input a User Profile. And not giving me any selections of previous User Profiles I entered.

Where can I get version 18?

more options

If there aren't any files in %APPDATA%\Mozilla\Firefox then try to remove the Firefox folder and also the parent Mozilla folder if you do not have other Mozilla programs that have their profile folder here.

Note that Windows hides the .ini file extension by default, so you may only see a profiles file without file extension.

Try to boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.

more options

I know this is an old thread but I had a similar problem in v23 and my solution might be helpful to others.

It turned out my start-up icon on the desktop had an extra parameter '-p default'. This parameter I added long time ago for being able to have two different versions of FireFox on the computer and had forgotten about. After removing these extra parameters the problem was fixed. I could also have fixed it by deleting the FF desktop icon and creating a new one.