Join the AMA (Ask Me Anything) with Firefox leadership team to talk about Firefox priorities in 2024. Mark your calendar! Thursday, June 13, 17:00 - 19:00 UTC.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Windows 7, FF 18.0.1 "NSSUTIL_EscapeSize couldn't find in dll nssutil3.dll" then "Could not load XPCOM" help please

  • 6 uphendule
  • 5 zinale nkinga
  • 6 views
  • Igcine ukuphendulwa ngu cor-el

more options

The problem doesn't resolve, I then re-install 17.0.1 and works fine. Have tried this install with 18.0 and 18.0.1 same results

The problem doesn't resolve, I then re-install 17.0.1 and works fine. Have tried this install with 18.0 and 18.0.1 same results

Okulungisiwe ngu DGB

All Replies (6)

more options

Do a clean reinstall and delete the Firefox program folder before reinstalling a fresh copy of Firefox.

  • (32 bit Windows) C:\Program Files\Mozilla Firefox\
  • (64 bit Windows) C:\Program Files (x86)\Mozilla Firefox\

Download a fresh Firefox copy and save the file to the desktop.

Uninstall your current Firefox version, if possible, to cleanup the Windows registry and settings in security software.

  • Do NOT remove personal data when you uninstall your current Firefox version, because all profile folders will be removed and you will also lose your personal data like bookmarks and passwords from profiles of other Firefox versions.

Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer.

Your bookmarks and other profile data are stored in the Firefox Profile Folder and won't be affected by an uninstall and (re)install, but make sure that "remove personal data" is NOT selected when you uninstall Firefox.


more options

I followed the steps you have suggested, when I started FF 18.0.1 I still received the error "Could not load XPCOM". I reran this process to delete and remove FF 18, then ran Malwarebytes, no problems found, and cleaned the registry, then reinstalled FF 18. again the error "Could not load XPCOM" appeared again. I have reverted back to FF 17. Any other ideas to resolve this?

Thanks

more options

You did delete the Firefox program folder, because such issues are usually caused by a failed update to some files?

more options

Yes I deleted the Firefox program directory as per instructions. I think I will try a custom install and select a different directory for the program installed location.

more options

I just installed Firefox 18.0.1 in a different directory and Firefox now starts error free. Thanks for your support cor-el your input lead me to the solution,

more options

You're welcome