X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How to prevent firefox to save a file when opening it in a new tab?

Kuphostiwe

When I am trying to just open a file from my e-mail attachments, for example, Firefox automatically saves the file, even if I chose "open in a new tab". As far as I understand Firefox should only open the file, not save it to my HD. How can I fix this ?

When I am trying to just open a file from my e-mail attachments, for example, Firefox automatically saves the file, even if I chose "open in a new tab". As far as I understand Firefox should only open the file, not save it to my HD. How can I fix this ?

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 11.5 r502
  • Näyttää Java-sovelman sisällön tai paikanvaraajan, jos Javaa ei ole asennettu.
  • QuickTime-liitännäisen avulla voit katsella monenlaista verkkosivuilla olevaa multimediasisältöä. Lisätietoja saat QuickTimen verkkosivustolta.
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • 5.1.10411.0
  • iPhoto6

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:17.0) Gecko/20100101 Firefox/17.0

Eminye Imininingwane

Honestly, I have no idea what to do. I have been trying to search from configurations of Firefox and my computer, but without any results.

Gingerbread Man 403 izisombululo 1537 izimpendulo
Kuphostiwe

Then the server is almost certainly sending the Content-Disposition: attachment header. You can verify this using the Web Console — check the response headers for the file in question.

As a workaround, you can install the following extension.

Then the server is almost certainly sending the ''Content-Disposition: attachment'' header. You can verify this using the Web Console — check the response headers for the file in question. * https://developer.mozilla.org/en-US/docs/Tools/Web_Console As a workaround, you can install the following extension. * https://addons.mozilla.org/firefox/addon/inlinedisposition/

Umnikazi wombuzo

I tried the extension, but did not help. I cannot understand what is wrong. Should I reinstall Firefox ?

I tried the extension, but did not help. I cannot understand what is wrong. Should I reinstall Firefox ?
cor-el
  • Top 10 Contributor
  • Moderator
17580 izisombululo 159069 izimpendulo
Kuphostiwe

Did you check via the Web Console (Web Developer > Web Console; Ctrl+Shift+K) how that file is send by the server?

See also:

Did you check via the Web Console (Web Developer > Web Console; Ctrl+Shift+K) how that file is send by the server? See also: *https://developer.mozilla.org/en/Using_the_Web_Console
Gingerbread Man 403 izisombululo 1537 izimpendulo
Kuphostiwe

Don't reinstall Firefox. It won't accomplish anything but waste your time. Use the Web Console to inspect the response headers for the file in question, like I mentioned earlier. See the attachment for an illustration of what to watch out for.

Firefox also needs to know the type of the file in order to know what to do with it (e.g. application/pdf can be opened with Adobe Reader, etc.). A generic (application/octet-stream), missing or incorrect MIME type is a server problem — assuming it's not intentional.
If that's the case, you can work around it using the Force Content-Type extension, however it's a bit complicated since it requires a knowledge of regular expressions. Do not install it unless you know for a fact that you need it.

Don't reinstall Firefox. It won't accomplish anything but waste your time. Use the Web Console to inspect the response headers for the file in question, like I mentioned earlier. See the attachment for an illustration of what to watch out for. Firefox also needs to know the type of the file in order to know what to do with it (e.g. ''application/pdf'' can be opened with Adobe Reader, etc.). A generic (''application/octet-stream''), missing or incorrect MIME type is a server problem — assuming it's not intentional.<br> If that's the case, you can work around it using the [https://addons.mozilla.org/firefox/addon/force-content-type/ Force Content-Type] extension, however it's a bit complicated since it requires a knowledge of [https://en.wikibooks.org/wiki/Regular_Expressions regular expressions]. Do not install it unless you know for a fact that you need it.

Umnikazi wombuzo

Ok, I found the web consol and this: Content-Type:text/html; charset=UTF-8

Mmm...what should I do with this information ? As you can see I am no expert by any means and this is a bit frustrating. How can it be so difficult ? This ain't a big issue, but still I find it very annoying, Thanks for trying to help me out !

Ok, I found the web consol and this: Content-Type:text/html; charset=UTF-8 Mmm...what should I do with this information ? As you can see I am no expert by any means and this is a bit frustrating. How can it be so difficult ? This ain't a big issue, but still I find it very annoying, Thanks for trying to help me out !

Umnikazi wombuzo

I could not find the Content disposition, however.

I could not find the Content disposition, however.

Umnikazi wombuzo

Oh, I found it ! Content-Disposition:inline;filename="l_32520121123fi00010008.pdf"

Now, what should I do about it ?

Oh, I found it ! Content-Disposition:inline;filename="l_32520121123fi00010008.pdf" Now, what should I do about it ?

Umnikazi wombuzo

And the Content Type was actually: Content-Type:application/pdf

And the Content Type was actually: Content-Type:application/pdf
cor-el
  • Top 10 Contributor
  • Moderator
17580 izisombululo 159069 izimpendulo
Kuphostiwe

Impendulo Ewusizo

We have seen reports that the PDF plugin isn't working properly on Mac, so it is best to open PDF file in an external reader application (Adobe Reader or Preview).

You can check the settings in Preferences > Applications

  • Firefox > Preferences > Applications > Adobe PDF document : Use Adobe Reader

PDF files may also be found under another entry like Portable document.

We have seen reports that the PDF plugin isn't working properly on Mac, so it is best to open PDF file in an external reader application (Adobe Reader or Preview). You can check the settings in Preferences > Applications *Firefox > Preferences > Applications > Adobe PDF document : Use Adobe Reader PDF files may also be found under another entry like Portable document. *https://support.mozilla.org/kb/change-firefox-behavior-when-open-file

Umnikazi wombuzo

Did not help. And the problem occurs with every kind of files (doc.-files for example).

Did not help. And the problem occurs with every kind of files (doc.-files for example).
cor-el
  • Top 10 Contributor
  • Moderator
17580 izisombululo 159069 izimpendulo
Kuphostiwe

Firefox only handles text/html and text/plain files and a few other MIME types internally.
All other files need to be opened in an external application application or make use of a possible plugin for Firefox.
You can set and manage which action Firefox takes as explained in the above posted knowledge base article.

Firefox only handles text/html and text/plain files and a few other MIME types internally.<br /> All other files need to be opened in an external application application or make use of a possible plugin for Firefox.<br /> You can set and manage which action Firefox takes as explained in the above posted knowledge base article.

Umnikazi wombuzo

Ok, I guess I have no choise but to change the browser to an easier one. Thank you everyone for trying to help out !

Ok, I guess I have no choise but to change the browser to an easier one. Thank you everyone for trying to help out !
Gingerbread Man 403 izisombululo 1537 izimpendulo
Kuphostiwe

I'm sorry if I overcomplicated things with the mention of server headers that can mess up Firefox's handling of files. They're unfortunately somewhat common, so I thought it was a likely possibility worth checking out (for that matter, I still don't know if in the above example Content-Disposition is inline by default, or as a result of having the Inline Disposition add-on installed).

In any case, if you hadn't given up, at this point you'd just have to make sure that for the Adobe Acrobat Document file type, the default action is Use Adobe Reader to open the file outside Firefox. The aforementioned article explains how to do this quickly, and there's even an illustration.

I'm sorry if I overcomplicated things with the mention of server headers that can mess up Firefox's handling of files. They're unfortunately somewhat common, so I thought it was a likely possibility worth checking out (for that matter, I still don't know if in the above example Content-Disposition is inline by default, or as a result of having the Inline Disposition add-on installed). In any case, if you hadn't given up, at this point you'd just have to make sure that for the ''Adobe Acrobat Document'' file type, the default action is '''Use Adobe Reader''' to open the file outside Firefox. The aforementioned article explains how to do this quickly, and there's even an illustration. * [[Change what Firefox does when you click on or download a file]]
m.d.w. 0 izisombululo 1 izimpendulo
Kuphostiwe

I am having the same issue and the same level of frustration as the person who originally posted this comment 2 weeks ago. Following the Firefox update this morning, I no longer have the option between opening a file and saving a file - the system automatically opens the save window. Is there any way to revert this setting to its previous state?

None of the suggestions that have been given thus far actually resolve this issue.

I am having the same issue and the same level of frustration as the person who originally posted this comment 2 weeks ago. Following the Firefox update this morning, I no longer have the option between opening a file and saving a file - the system automatically opens the save window. Is there any way to revert this setting to its previous state? None of the suggestions that have been given thus far actually resolve this issue.