Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

A link from another programme (Adobe Reader, eMail) take almost 2 minutes to show up in firefox. A link from a webpage in firefox opens in less than 2 seconds

  • 2 uphendule
  • 1 inale nkinga
  • 12 views
  • Igcine ukuphendulwa ngu cor-el

more options

Firefox v17.0, windows7. this is not related to the web page, all URLs present this issue. firefox is the default browser

All Replies (2)

more options

Hi,

You can try to Associate a file type or protocol with a program via the Windows Control Panel > Default Programs. Look for .url > (ignore existing Firefox) Change Program and Browse and select Firefox again.

Also, if you have security software (antivirus, firewall etc.) installed, you can try deleting all existing instances of Firefox and its related processes/files in all the different configuration modules/areas of the security software like process monitoring, sub/spawned process control, virtualization, HIPS etc., in addition to the security software's main configuration panel. Instead create new fully allowed/trusted rules for Firefox + its related processes in all the different modules/panels - a genuine/original Firefox installer as well as all the installed EXEs (Application) and DLLs (Application extension) are digitally signed by Mozilla Corporation (right-click > Properties > Digital Signatures). Even otherwise, some security software may also ask again when Firefox and/or its sub processes are started, and you may be able to allow/trust at that time. Please see this.

AV/Firewalls Configuration

more options