Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Can't open links in Firefox by clicking URL in Thunderbird

  • 49 uphendule
  • 39 zinale nkinga
  • Igcine ukuphendulwa ngu maccool

more options

This has started happening since the last Firefox upgrade (to 14.0.1). It affects two machines - one running Windows 7, the other XP. The symptoms are identical.

Firefox is the default browser on both machines. I'm using only a default profile on each machine. I've checked that there are no stray "no-remote" switches in the command line or environment variables and I've tried deleting "parent.lock". The fact that it has happened to two separate installations, as a result of the upgrade, and the fact that all other functions of Firefox work as expected, makes me doubt that it's a profile corruption. I have also tried opening Firefox in Safe Mode but the behaviour is the same.

Here's what happened/happens:

Previously, if I had opened Firefox in the normal way from the start menu and then clicked on a link in an email in Thunderbird, the link would open in a new tab in the running copy of Firefox. I could do this with multiple links, each opening a new tab.

Now, if I do this I get the "Firefox is already running" error box.

If I close Firefox the click on a link in an email in Thunderbird, it will start Firefox as expected, and open the link. But if I then click on a second link, I get the error message.

If I click on URLs in other applications (for instance Pidgin instant messenger), the links open in new tabs in the running Firefox in the usual way, so the problem seems to be specific to links opened in Thunderbird.

As an experiment, I rolled my FF installation back to 13.0.1 on the XP machines. Everything then worked as before, and as expected, so this is clearly to do with the upgrade.

All Replies (9)

more options

Agreed, maccool.

As the original poster, I'm a bit annoyed that the discussion has been allowed to drift so far from the original reported bug. It seems pretty clear that what is now being discussed bears no relevance to it.

And the original problem remains unresolved.

more options

Hi ratcatcher and maccool, sorry about the hijacking.

Could you check whether you have any "non-default" settings for the following preferences and test with the default settings.

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste tabs.load and pause while the list is filtered

(3) You can double-click any of the following to switch from true to the default value of false:

  • browser.tabs.loadDivertedInBackground (probably most relevant)
  • browser.tabs.loadInBackground
  • browser.tabs.loadBookmarksInBackground (probably not relevant)

Edit: You might need to exit and restart Firefox for this to take effect.

Okulungisiwe ngu jscher2000

more options

Not much point in apologising for hijacking the thread and then carrying on!

Why don't you take it to email?

more options

You know what ratcatcher you're right! Tried that as well as facebook and no one would respond!

more options

Not much point in apologising for hijacking the thread and then carrying on!

My reply was specifically for you and maccool. Did you check it?

more options

Sorry, jscher2000, there has been so much irrelevant traffic over the last few days that it didn't occur to me that your reply was to me.

With regard to the config settings:

browser.tabs.loadDivertedInBackground (probably most relevant) is set to the default of false

browser.tabs.loadInBackground is set to the default, which is true, not false

browser.tabs.loadBookmarksInBackground (probably not relevant) is set to the default of false

I have subsequently turned up some additional information on this problem:

I'm using the PortableApps version of Thunderbird. My ThunderbirdPortable.ini file contains the following line:


My understanding is that this invokes the -no-remote function. I do this because I run two instances of TB - one for my email and one for my wife's (as we share the same machine). All worked as expected up to FF version 14, then this issue started to occur.

If I remove that parameter it all works as expected but of course I can't then run two instances of TB.

If I leave the line in and tell TB to open links in a different browser (such as Google Chrome), again all works as expected.

So this seems to be down to some weird interaction between TB and FF with the -no-remote switch active on the former.



more options

I seem to be having the same situation. I remember this going on before but somehow fixed it. I am running the 16.0.2 version of a portable firfox with a 16.0.2 version of T-bird. With windows 8. (Side note I had windows 8 so much I am switching all my computers over to linux)

Seems like I got everything to open up in my firefox BUT t-bird still for some reason want to open up IE. I am at the end of my rope with this and I am just going to look for a tbird add-on that will open the links in a t-bird tab as a work around. Still will not be as good as opening up in my firefox but better than IE !!

more options

Score ! !

I at least got a workaround that worked for me. I found an addon that forces Tbird to open up links in whatever program (browser) you want. It says it it is made to open up in tabs in tbird and it will do that nicely too but you can also point it to open the links up in whatever you want. Looks like you could even have it open up in sea-monkey if you wanted because you put in the path to the program you want it to use.

Here it is:

Hope this helps other people too :)

Okulungisiwe ngu mr_shaffer

more options

@jscher2000 and @ratcatcher,

I just got back to this. I didn 't bother with checking the settings suggested, I zeroed in on the no-remote option. I have 2 business accounts and 1 personal account and 1 for my wife. I use the no-remote option to allow me to keep the emails segregated (keeps me from making email errors by mixing up where I am, strict silo'ing) and be able to have a look at all of them at the same time.

I just tried opening one account without the no-remote and it works as expected. Is this a bug that needs to be fixed?

  1. 1
  2. 2
  3. 3