Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Not remembering passwords

  • 2 uphendule
  • 2 zinale nkinga
  • Igcine ukuphendulwa ngu toneal

more options

I had changed my password on one of my sites I use every day. Thereafter, every time I would go to log in, it contained my old password, and I have reenter the new password. I went to the settings and ended up removing the saved passwords, thinking that it would prompt me to remember them again. I cannot seem to find how to get FF to remember my password again for this site.

I had changed my password on one of my sites I use every day. Thereafter, every time I would go to log in, it contained my old password, and I have reenter the new password. I went to the settings and ended up removing the saved passwords, thinking that it would prompt me to remember them again. I cannot seem to find how to get FF to remember my password again for this site.

All Replies (2)

more options

Check that there aren't any empty names or passwords visible in the Password Manager

  • Tools > Options > Security: Passwords: "Saved Passwords" > "Show Passwords"

The website may be using autocomplete=off to prevent Firefox from saving the name and password.


Make sure that you do not run Firefox in permanent Private Browsing mode.

To see all History and Cookie settings, choose: Tools > Options > Privacy, choose the setting Firefox will: Use custom settings for history

  • Deselect: [ ] "Always use private browsing mode"
more options

Thanks for your reply. Most of the things mentioned I had already tried. I ended up installing the addon for the Saved Password Editor and was able to get it working again, at least for the site I needed. (This issue was in FF ver 7.0.1 btw)