Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

I am urged to update to 6, but it isn't compatible to my Avast .... tell why I should hurry. Are you hurrying to make it compatible??

more options

I have Avast antivirus. This update and the last one ... Firefox 5 were not compatible to my Avast and your program said I had to disable my antivirus to update. I think NOT! Why don't you release a browser that is compatible to Avast? And, specifically, WHEN will you guys get on the ball and do that? I like Firefox ... but I won't cut off my nose to spite my face fellas ....

All Replies (1)

more options

Sorry, but add-on compatibility is the responsibility of whoever made the add-on, not Firefox. See Avast for an updated version of their Web Rep Firefox add-on.

Or go ahead with the Firefox 6.0 update and then do a manual update of your Avast program from the System Try icon for Avast.

Okulungisiwe ngu the-edmeister