X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

The update could not be installed. Please make sure there are no other copies of Firefox running on your computer, and then restart Firefox to try again.

Kuphostiwe

Before I start Fire Fox I open the Task Manager to make sure no other copies of Fire Fox are running. When I click on the short cut there is a pause of about 1 second then this message appears. "The update could not be installed. Please make sure there are no other copies of Firefox running on your computer, and then restart Firefox to try again." I checked your FAQs where this problem showed up many times. I saw not solutions there. Where can I go to get an answer other than the usual remarks. Of course Fire Fox starts up immediately after the error message.

This happened

Every time Firefox opened

== This morning 6/25/2010

Before I start Fire Fox I open the Task Manager to make sure no other copies of Fire Fox are running. When I click on the short cut there is a pause of about 1 second then this message appears. "The update could not be installed. Please make sure there are no other copies of Firefox running on your computer, and then restart Firefox to try again." I checked your FAQs where this problem showed up many times. I saw not solutions there. Where can I go to get an answer other than the usual remarks. Of course Fire Fox starts up immediately after the error message. == This happened == Every time Firefox opened == This morning 6/25/2010

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • -Version 1.2.0.0
  • Default Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape "9.3.2"
  • Google Update
  • Shockwave Flash 10.1 r53
  • iTunes Detector Plug-in
  • GEPlugin
  • Yahoo Application State Plugin version 1.0.0.7
  • 4.0.50524.0
  • Office Live Update v1.5
  • NPWLPG
  • Next Generation Java Plug-in 1.6.0_20 for Mozilla browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

Eminye Imininingwane

I opened Windows Task Manager to make sure no other copies of Fire Fox was running and I also check the Processes. No help.

Umnikazi wombuzo

gaaah i have the same issue

gaaah i have the same issue
cor-el
  • Top 10 Contributor
  • Moderator
17583 izisombululo 159079 izimpendulo
Kuphostiwe

Impendulo Ewusizo

See http://kb.mozillazine.org/Software_Update (Software Update not working properly)

Remove the files in the updates and updates\0 folder:

XP:

C:\Documents and Settings\<user>\Local Settings\Application Data\Mozilla\Firefox\Mozilla Firefox\updates
%USERPROFILE%\Local Settings\Application Data\Mozilla\Firefox\Mozilla Firefox\updates
C:\Program Files\Mozilla Firefox\updates

Vista/Windows7:

C:\Users\<user>\AppData\Local\Mozilla\Firefox\Mozilla Firefox\updates
%LOCALAPPDATA%\Mozilla\Firefox\Mozilla Firefox\updates
C:\Users\<user>\AppData\Local\VirtualStore\Program Files\Mozilla Firefox\updates
See http://kb.mozillazine.org/Software_Update (Software Update not working properly) Remove the files in the ''updates'' and ''updates\0'' folder: XP: C:\Documents and Settings\&lt;user&gt;\Local Settings\Application Data\Mozilla\Firefox\Mozilla Firefox\updates %USERPROFILE%\Local Settings\Application Data\Mozilla\Firefox\Mozilla Firefox\updates C:\Program Files\Mozilla Firefox\updates Vista/Windows7: C:\Users\&lt;user&gt;\AppData\Local\Mozilla\Firefox\Mozilla Firefox\updates %LOCALAPPDATA%\Mozilla\Firefox\Mozilla Firefox\updates C:\Users\&lt;user&gt;\AppData\Local\VirtualStore\Program Files\Mozilla Firefox\updates

Okulungisiwe ngu cor-el

mrsteevj 0 izisombululo 1 izimpendulo
Kuphostiwe

ahh thanks, tht was helpful :)

ahh thanks, tht was helpful :)
filbert 0 izisombululo 9 izimpendulo
Kuphostiwe

Nothing worked for me except downloading and installing over the existing installation. This was the case for both FF6 and TB6 on my win7 64 bit system.

Nothing worked for me except downloading and installing over the existing installation. This was the case for both FF6 and TB6 on my win7 64 bit system.
al_alkan 0 izisombululo 1 izimpendulo
Kuphostiwe

I use Peppermint Linux with Firefox 4.0. Higher update versions of Firefox cause problems... then I disabled automatic updates.

Even with updates disabled in the advanced tools, I get this (...update could not be installed. Please...) identical window message pop up every time I start Firefox. Before the Firefox program will start, my Task bar will show the Firefox Icon with the word 'Update' on it and my Linux Task manager suddenly gets Firefox.bin. in it. I erased all 'update' hidden files in the Mozilla folder.

After killing the pop up by using the pop up window's X 4.0 will start or if I use Task manager to "kill" Firefox.bin, ("stop" will freeze my Peppermint program and I have to reboot) then the pop up window goes away. Once I kill the pop up window, Firefox 4.0 actually starts -- and all works fine. No updates ever actually try to install.

How do I stop this pop up message that has to be killed before Firefox runs? I don't want to Update and 4.0 is fine. Thank you in advance.

I use Peppermint Linux with Firefox 4.0. Higher update versions of Firefox cause problems... then I disabled automatic updates. Even with updates disabled in the advanced tools, I get this (...update could not be installed. Please...) identical window message pop up every time I start Firefox. Before the Firefox program will start, my Task bar will show the Firefox Icon with the word 'Update' on it and my Linux Task manager suddenly gets Firefox.bin. in it. I erased all 'update' hidden files in the Mozilla folder. After killing the pop up by using the pop up window's X 4.0 will start or if I use Task manager to "kill" Firefox.bin, ("stop" will freeze my Peppermint program and I have to reboot) then the pop up window goes away. Once I kill the pop up window, Firefox 4.0 actually starts -- and all works fine. No updates ever actually try to install. How do I stop this pop up message that has to be killed before Firefox runs? I don't want to Update and 4.0 is fine. Thank you in advance.

Okulungisiwe ngu al_alkan

muhibu 0 izisombululo 1 izimpendulo
Kuphostiwe

I have managed to stop that error message from popping up before the window loads up,

I deleted the entire updates folder from the program directory

C:\Program Files\Mozilla Firefox\Updates

now i dont get the silly message, firefox seems to be working fine :)

hope this helps

I have managed to stop that error message from popping up before the window loads up, I deleted the entire updates folder from the program directory C:\Program Files\Mozilla Firefox\Updates now i dont get the silly message, firefox seems to be working fine :) hope this helps
butcher99 0 izisombululo 3 izimpendulo
Kuphostiwe

this worked for me. I went into the updates folder and deleted everything in it. problem solved. Be back if it reappears.

this worked for me. I went into the updates folder and deleted everything in it. problem solved. Be back if it reappears.
Arshan 0 izisombululo 1 izimpendulo
Kuphostiwe

Impendulo Ewusizo

None of these files exist on my computer. Unable to use the info.

None of these files exist on my computer. Unable to use the info.
hedda3000 0 izisombululo 1 izimpendulo
Kuphostiwe

I have been searching through several forums to find a solution to this problem, and the only resolution I see is to delete the Updates folder, or files within it. Does the folder repopulate, or does this effectively disable updates?

Disabling updates doesn't sound like a very good idea to me.

I have this problem on my personal computer as well as my work computer, and on both I log on with an administrative account. It looks to me like there is a problem with the latest update.

UAC asks me if I will allow Firefox to make changes to my hard drive, I say yes, and then I get the error message above.

I have been searching through several forums to find a solution to this problem, and the only resolution I see is to delete the Updates folder, or files within it. Does the folder repopulate, or does this effectively disable updates? Disabling updates doesn't sound like a very good idea to me. I have this problem on my personal computer as well as my work computer, and on both I log on with an administrative account. It looks to me like there is a problem with the latest update. UAC asks me if I will allow Firefox to make changes to my hard drive, I say yes, and then I get the error message above.
bluecup 1 izisombululo 6 izimpendulo
Kuphostiwe

This solution does work for me on Firefox version 10.0.2.

This solution does work for me on Firefox version 10.0.2.
jobmiller 0 izisombululo 6 izimpendulo
Kuphostiwe

This seems to be a windows 7 thing. Every version of Firefox in windows 7 has had this problem. It still exists for Firefox and Thunderbird release 12. Deleting the updates only delays the problem. It comes right back as soon as firefox retrieves the update again when you click on the about menu i think.

Why has no one from the Firefox development community taken a look at this and fixed it? The install/update is a large part of user experience, and it seems that almost a 1k people have this problem that have reported it here.

This seems to be a windows 7 thing. Every version of Firefox in windows 7 has had this problem. It still exists for Firefox and Thunderbird release 12. Deleting the updates only delays the problem. It comes right back as soon as firefox retrieves the update again when you click on the about menu i think. Why has no one from the Firefox development community taken a look at this and fixed it? The install/update is a large part of user experience, and it seems that almost a 1k people have this problem that have reported it here.
Mikey2 0 izisombululo 2 izimpendulo
Kuphostiwe

I finally figured this out and updated to version 13!

Ironically it was a feature specified in the new version that was causing the problem. It said that the new updates will no longer require a UAC dialog. That is incorrect, one must start Firefox as administrator so one no longer sees that message.

I have switched over to Chrome for a while now, I decided to check back in to Firefox to see if things have gotten better. (I was a dedicated Firefox user since the start.) I guess I am staying back on Chrome until Mozilla gets their stuff together. It is sad to say, but Chrome is still far superior and MUCH faster than this "new" bloated firefox, regardless of how many full-number "updates" they make. (Sorry, but version 13.0? That's a joke...14.0 will probably have a single bug-fix - perhaps fixing my inability to use the new "pin"-tab. :/)

OK rant over, to put it simply, if you get this error:

  1. Make sure you have no other versions of firefox running (I even check Task Manager and make sure there are no other Firefox processes running.)
  2. Right-click your firefox icon and select "Run as Administratror."
  3. Select "Yes" at the UAC prompt.

That should do it! Good luck Mozilla, I will try again in a few months... MikeY

EDIT - I should note that I first followed the other post and deleted my update directories before trying to do this. I know that without doing my step, it did not work; however, I do not know if deleting the folders is also necessary.

I finally figured this out and updated to version 13! Ironically it was a feature specified in the new version that was causing the problem. It said that the new updates will no longer require a UAC dialog. That is incorrect, one must start Firefox as administrator so one no longer sees that message. I have switched over to Chrome for a while now, I decided to check back in to Firefox to see if things have gotten better. (I was a dedicated Firefox user since the start.) I guess I am staying back on Chrome until Mozilla gets their stuff together. It is sad to say, but Chrome is still far superior and MUCH faster than this "new" bloated firefox, regardless of how many full-number "updates" they make. (Sorry, but version 13.0? That's a joke...14.0 will probably have a single bug-fix - perhaps fixing my inability to use the new "pin"-tab. :/) OK rant over, to put it simply, if you get this error: # Make sure you have no other versions of firefox running (I even check Task Manager and make sure there are no other Firefox processes running.) # Right-click your firefox icon and select "Run as Administratror." # Select "Yes" at the UAC prompt. That should do it! Good luck Mozilla, I will try again in a few months... MikeY EDIT - I should note that I first followed the other post and deleted my update directories before trying to do this. I know that without doing my step, it did not work; however, I do not know if deleting the folders is also necessary.

Okulungisiwe ngu Mikey2

jscher2000
  • Top 10 Contributor
8797 izisombululo 71955 izimpendulo
Kuphostiwe

If the "silent" updates cause a problem, you can disable them here:

orange Firefox button or classic Tools menu > Options > Advanced > Update > uncheck the box for "Use a background service to install updates"

As for what is updated in Firefox's latest release, you can check out the Release Notes and detailed bug list.

If the "silent" updates cause a problem, you can disable them here: orange Firefox button ''or'' classic Tools menu > Options > Advanced > Update > ''uncheck'' the box for "Use a background service to install updates" As for what is updated in Firefox's latest release, you can check out the [https://www.mozilla.org/en-US/firefox/13.0/releasenotes/ Release Notes] and [https://www.mozilla.org/en-US/firefox/13.0/releasenotes/buglist.html detailed bug list].