Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How to make Firefox 83.0 support private fields?

  • 6 uphendule
  • 0 zinale nkinga
  • 2 views
  • Igcine ukuphendulwa ngu cor-el

more options

Hello, I am using firefox 83.0 and I don't want to update it (Why? Because I've an old PC with poor hardware and the playback of online videos is lagging/shuttering in releases after 83.0)

BUT firefox 83.0 doesn't support private fields which make some webpages unable to be loaded. the private fields was supported starting in release 90.0 and I'm using 83.0

So, I need a way to make firefox 83.0 support private fields, Is that possible? Is there a certain files should I edited or replaced to make it support private fields?

Any ideas would be appreciated.

Hello, I am using firefox 83.0 and I don't want to update it (Why? Because I've an old PC with poor hardware and the playback of online videos is lagging/shuttering in releases after 83.0) BUT firefox 83.0 doesn't support private fields which make some webpages unable to be loaded. the private fields was supported starting in release 90.0 and I'm using 83.0 So, I need a way to make firefox 83.0 support private fields, Is that possible? Is there a certain files should I edited or replaced to make it support private fields? Any ideas would be appreciated.

All Replies (6)

more options

Go to about:config and create javascript.options.experimental.private_fields (Boolean) with value true then restart the browser. This setting was first introduced in version 80 so there may be some experimental support in 83.

more options

zeroknight said

Go to about:config and create javascript.options.experimental.private_fields (Boolean) with value true then restart the browser. This setting was first introduced in version 80 so there may be some experimental support in 83.

I appreciate your answer, but unfortunately it doesn't work these website are still not loaded correctly and it says in web console section "Uncaught SyntaxError: private fields are not currently supported"

more options

Did you try to disable fission in newer Firefox versions ?

You can control Fission via fission.autostart on the about:config page, true to enable and false to turn it off.

  • about:config => fission.autostart = false

With fission disabled, you can modify the number of content processes. You can test this in 91 ESR.

All Firefox releases on the Mozilla server:

Make sure that you do not launch Firefox after installing, but use the Profile Manager to create a new profile and use a desktop shortcut to launch this version with its own profile (add -P profile to the target line).

more options

cor-el said

Did you try to disable fission in newer Firefox versions ? You can control Fission via fission.autostart on the about:config page, true to enable and false to turn it off.
  • about:config => fission.autostart = false
With fission disabled, you can modify the number of content processes. You can test this in 91 ESR. All Firefox releases on the Mozilla server: Make sure that you do not launch Firefox after installing, but use the Profile Manager to create a new profile and use a desktop shortcut to launch this version with its own profile (add -P profile to the target line).

I really appreciate your answer, I tried the solution but the playback of online videos is still shuttering specially on YouTube.

Looks like the behavior of video playback differs in later versions for some reason.

more options

It may help to find exactly when video playback issues started with mozregression.

more options

YouTube may prefer codec that do not work well on your device with software decoding. Try this extension: