Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

NordVPN installed a management profile, now I can't get rid of it

  • 8 uphendule
  • 2 zinale nkinga
  • 347 views
  • Igcine ukuphendulwa ngu Mike

more options

As the title says:

NordVPN's Threat Protection installed a browser management profile. Now, I can't seem to get rid of it. I've refreshed FireFox, uninstalled NordVPN using App Cleaner, and deleted any/all certs for NordVPN Threat Protection from keychain access.

How can I get rid of the management profile? See attached screenshots.

MacOS: 13.4.1 FF: 114.0.2 (64-bit)

As the title says: NordVPN's Threat Protection installed a browser management profile. Now, I can't seem to get rid of it. I've refreshed FireFox, uninstalled NordVPN using App Cleaner, and deleted any/all certs for NordVPN Threat Protection from keychain access. How can I get rid of the management profile? See attached screenshots. MacOS: 13.4.1 FF: 114.0.2 (64-bit)
Ama-screenshot ananyekiwe

Isisombululo esikhethiwe

Do you have a policies.json file in Firefox.app/Contents/Resources/distribution?

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 3

All Replies (8)

more options

I’ve opened a ticket with them.

So there’s no way to remove this from Firefox’s end?

more options

from /questions/1412493

Seeing the "Your browser is being managed by your organization" notification at the top of the Settings page is in most cases caused by security software that uses GPO policy rules (ImportEnterpriseRoots) to inject their root certificate in Firefox to be able to intercept and scan your internet traffic. You can click the "Your browser is being managed by your organization" notification or open the about:policies page to see if policies are active and if errors are reported. You can check the connection settings.
  • Settings -> General -> Network: Connection -> Settings
If you do not need to use a proxy to connect to internet, select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly. See "Firefox connection settings":
more options

Dropa said

You need to contact Nord VPN support since this is their software.

Or you can do some research and give some help here also.

more options

You can click the "Your browser is being managed by your organization" notification or open the about:policies page to see if policies are active and if errors are reported.

Seeing the "Your browser is being managed by your organization" notification at the top of the Settings page is in most cases caused by third-party software that uses GPO policy rules or uses a policies.json file in the distribution folder in the profile folder to inject their certificate in Firefox to be able to hook into your internet connection.

The mere presence of the "Mozilla\Firefox\" key is sufficient to make Firefox display this notification, so if you have the Firefox key then remove it and only leave the Mozilla key or remove this key as well if it is empty.

  • HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Mozilla\Firefox\ =>
    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\
more options

Please read my question and information I provided in its entirety. Doing so will keep you from wasting your time by sharing information that is either irrelevant or already been shared.

- The screenshots I provided indicate that I clicked on the "your browser is being managed" link - The system information indicates that I am on MacOS.

NordVPN support asked me to disable their Web protection, which I did. I also completely uninstalled their application. Neither of these have had any impact.

Okulungisiwe ngu Mike

more options

Isisombululo Esikhethiwe

Do you have a policies.json file in Firefox.app/Contents/Resources/distribution?

more options
more options

TyDraniu said

Do you have a policies.json file in Firefox.app/Contents/Resources/distribution?

Yes! I deleted that file and restarted Firefox and the management policy, including the "Your browser is being managed by your organization" item in the settings is now gone.

Thanks!