Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

search box on Firefox home page

  • 3 uphendule
  • 1 inale nkinga
  • 121 views
  • Igcine ukuphendulwa ngu books5

more options

Trying to use the seach box in the centre of the Firefox homepage (google search engine) .. everything I type goes up to the address bar . Tried changing settings - I see there's a search box option in the 'tool bar' which looks to be up at the side of the address bar. cant understand why we need another one as well as the one in the centre.

Also by turning off suggestions and not choosing the 'search box option in the 'tool bar' , the address bar is now only accepting URLs so searching isnt working.

So ..1. Is the search box in the centre no use?

        2.  Does search work with all suggestions turned off?
Trying to use the seach box in the centre of the Firefox homepage (google search engine) .. everything I type goes up to the address bar . Tried changing settings - I see there's a search box option in the 'tool bar' which looks to be up at the side of the address bar. cant understand why we need another one as well as the one in the centre. Also by turning off suggestions and not choosing the 'search box option in the 'tool bar' , the address bar is now only accepting URLs so searching isnt working. So ..1. Is the search box in the centre no use? 2. Does search work with all suggestions turned off?

Isisombululo esikhethiwe

You can turn it off by entering about:config in the URL bar and switching browser.newtabpage.activity-stream.improvesearch.handoffToAwesomebar to false.

WARNING: Changing preferences through this interface not officially supported Hidden settings edited using the about:config tool are explicitly not supported, which means that Mozilla makes no guarantees they will be supported in the future, or that Mozilla will fix them if they break. Mozilla does not test these preferences, and will not in the future. That includes security and performance testing which these preferences may affect.

[Warning added by moderator]

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (3)

more options

Isisombululo Esikhethiwe

You can turn it off by entering about:config in the URL bar and switching browser.newtabpage.activity-stream.improvesearch.handoffToAwesomebar to false.

WARNING: Changing preferences through this interface not officially supported Hidden settings edited using the about:config tool are explicitly not supported, which means that Mozilla makes no guarantees they will be supported in the future, or that Mozilla will fix them if they break. Mozilla does not test these preferences, and will not in the future. That includes security and performance testing which these preferences may affect.

[Warning added by moderator]

Okulungisiwe ngu Chris Ilias

more options

Excellent - works a treat .. thanks

more options

Thanks for the fix. It's wonderfully ironic how the idiotic setting you need to turn OFF to make things better is called both "improve" and "awesome". Somebody needs a dictionary!