On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Vertical scroll bar jumps and skips down especially on long pages

  • 3 uphendule
  • 1 inale nkinga
  • 136 views
  • Igcine ukuphendulwa ngu flexmcmurphy

more options

I know this question has been asked before but I am hoping for an update and maybe to learn something new to try...

I installed the latest Firefox (April 2021) on Ubuntu mate 64 bit.

I use my laptop Touchpad to move the cursor around on web pages. I go to the vertical scroll bar to scroll down the page... I left click on the scroll bar, hold the left button, then start dragging down on the Touchpad but.

Often, when I am on a web page that is long, the scroll bar will jump and skip all the way to the bottom of the screen even though I'm just dragging it down a little and slowly too. Sometimes the scroll bar keeps racing down the page even when I am not dragging the cursor down at all.

I don't notice this behavior in Chrome or Brave or in other Ubuntu mate user interface elements.

This question has been asked before e.g: https://support.mozilla.org/en-US/questions/1314677

I tried solutions in that question such as going in to about:config and tried... general.smoothScroll.scrollbars.durationMaxMS (changed this from 150 to 75) general.smoothScroll.scrollbars.durationMinMS (changed this from 150 to 50)

I also downgraded to Firefox 82.0.3 but this has not solved the problem either.

Is this a known bug that is being worked on? What else can I try apart from switching back to Brave?

Cheers,

Flex

I know this question has been asked before but I am hoping for an update and maybe to learn something new to try... I installed the latest Firefox (April 2021) on Ubuntu mate 64 bit. I use my laptop Touchpad to move the cursor around on web pages. I go to the vertical scroll bar to scroll down the page... I left click on the scroll bar, hold the left button, then start dragging down on the Touchpad but. Often, when I am on a web page that is long, the scroll bar will jump and skip all the way to the bottom of the screen even though I'm just dragging it down a little and slowly too. Sometimes the scroll bar keeps racing down the page even when I am not dragging the cursor down at all. I don't notice this behavior in Chrome or Brave or in other Ubuntu mate user interface elements. This question has been asked before e.g: https://support.mozilla.org/en-US/questions/1314677 I tried solutions in that question such as going in to about:config and tried... general.smoothScroll.scrollbars.durationMaxMS (changed this from 150 to 75) general.smoothScroll.scrollbars.durationMinMS (changed this from 150 to 50) I also downgraded to Firefox 82.0.3 but this has not solved the problem either. Is this a known bug that is being worked on? What else can I try apart from switching back to Brave? Cheers, Flex

Isisombululo esikhethiwe

Recap of Observed Problem: I am using a trackpad to control the cursor in Firefox. If I place the cursor a few pixels to the left or right of the Vertical scroll bar "Slider" (and not exactly ON the Slider) then press the trackpad left button then the Slider moves erratically up or down scrolling the page with it. Sometimes the Slider will skip down the screen very quickly even if I am not dragging my finger across the trackpad to move the Slider.

My Solution: I have investigated this further and now I think the issue is a consequence of the design of the Vertical scrollbars in Ubuntu mate.

I created this file in my home folder: /home/flex/.config/gtk-3.0/gtk.css

With this contents:

scrollbar slider {

   /* Size of the slider */
   min-width: 15px;
   min-height: 15px;
   border-radius: 17px;
   /* Padding around the slider */
   border: 2px solid transparent;

}

Now the problem has gone away.

The issue described in this thread was not a Firefox issue.

Flex

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (3)

more options

Since I cannot edit my question, here is some more info about my situation:

Use smooth scrolling = enabled Use autoscrolling = disabled Always use the cursor keys to navigate within pages = disabled

more options

As another update... Today I installed Manjaro/KDE in Virtualbox (manjaro-kde-21.0.2-210419-linux510.iso)

I don't have this problem with the vertical scroll bar skipping down the page in Firefox running in Manjaro. I also installed Brave in the same OS and couldn't reproduce the problem with that browser either.

Flex

more options

Isisombululo Esikhethiwe

Recap of Observed Problem: I am using a trackpad to control the cursor in Firefox. If I place the cursor a few pixels to the left or right of the Vertical scroll bar "Slider" (and not exactly ON the Slider) then press the trackpad left button then the Slider moves erratically up or down scrolling the page with it. Sometimes the Slider will skip down the screen very quickly even if I am not dragging my finger across the trackpad to move the Slider.

My Solution: I have investigated this further and now I think the issue is a consequence of the design of the Vertical scrollbars in Ubuntu mate.

I created this file in my home folder: /home/flex/.config/gtk-3.0/gtk.css

With this contents:

scrollbar slider {

   /* Size of the slider */
   min-width: 15px;
   min-height: 15px;
   border-radius: 17px;
   /* Padding around the slider */
   border: 2px solid transparent;

}

Now the problem has gone away.

The issue described in this thread was not a Firefox issue.

Flex