Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Checking for updates

  • 11 uphendule
  • 1 inale nkinga
  • 308 views
  • Igcine ukuphendulwa ngu Scribe

more options

So, right now, I am using another web browser and that is because when I use Firefox, it checks for updates way too often. Every five or ten minutes it checks for updates and SLOWS my internet down. Is there a way to change this frequency? I do not want it to stop or anything, but why every 5 or 10 minutes does it have to check for updates? The older versions of Firefox, you could change the frequency and such of this. This made the web browser usable for me because I am on a slower connection.

All Replies (11)

more options

Enter about:config in the URL bar and check the value of the app.update.interval preference.

more options

That does not solve my problem as this seems to be for updating Firefox. What the issue is the checking for updates. If this is the problem, there is a bug because it is set for 43200, which I believe is suppose to be like every 12 hours, but on my system, it checks every 15 minutes. ( about this because I only notice when my internet takes a nose dive).

more options

Are you sure this is from Firefox? Do you still have the problem with Firefox closed?

Also,

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

more options

Sigh. Yes. The problem is Firefox. The checking for updates happens every 15 mins or so. That takes up the speed of my internet. I would just like to change to how often the browser checks for updates. It used to be, you could check for updates yourself, but recent updates does this automatically. I am on DSL connection, which means any extra strain on the line slows my speed down. Having checking for updates go as often as is does makes not want to use the browser. I hope this clear things up.

more options

FredMcD said

Also, Start Firefox in Safe Mode {web link}
more options

I tried this and changed the value of the app.update.interval preference. Sorry for the earlier annoyance. Was told that this is the correct thing to change the check for updates. Just changed it to a higher number. Not sure if this will help the issue or not, but I will post back if the issue is still here. Thanks for the suggestions so far.

more options

Okay. Value changed and was suppose to keep the updates shorts, but I really think there is a bug in the browser, as changing the value has done nothing. Been keeping track of how often the browser checks for updates and since about 3pm this afternoon, it has checked for updates 11 times. I have never had any other program check for updates that often in one day, especially since one time it checked for updates at 4:41pm and 3 minutes later, another check for updates occurred. It really does slow down my internet and computer, so this alone really puts me off on this browser.

more options

This is a long shot. Check that the value of app.update.channel is default.

more options

If you can't fix the issue, I would remove the software and install it anew, using a new profile altogether. [Manager - Create, remove, or switch Firefox profiles]

more options

You have not said if you tried Safe Mode.

more options

Hi, try changing app.update.checkInstallTime to False then restart Firefox. It has reduced the nag frequency for me to once a day on several machines. I've wasted hours on this, and many of the prefs that used to work seem not to do so any more.

If all else fails, there seems to be a policy coming in Firefox 87 (scheduled for stable release 23rd March) that will stop the notifications but allow manual updates: https://bugzilla.mozilla.org/show_bug.cgi?id=1653430

Current policies: https://github.com/mozilla/policy-templates/blob/master/README.md