Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Share a webpage

  • 1 baphendule
  • 2 zinale nkinga
  • 72 views
  • Igcine ukuphendulwa ngu Rich

more options

The browser Safari, which I quit in favour of Firefox, has a command. "Email this page". What's the equivant in Firefox?

All Replies (1)

more options

I had to go to the Firefox Help page to find out where they hid the Share function for a webpage (Hint: Right-Click the Tab for the page). Now I find out that I cannot share a webpage using my Mail application on macOS Big Sur (v11.3.1). I can share the page using the "Add to Photos", Notes, Add to Reading List, Reminders, Copy Link, Pocket, and Save to Books extensions. But I cannot share it using the Mail, AirDrop, Messages, and iCloud Sharing Extensions. These options have a "greyed out" check mark next to them in the Systems Preferences > Extensions > Share Menu screen. I guess that means there must be a security reason these Extensions don't work. It looks like the workaround is to go back to Safari to "Email this page" until Firefox figures out how to fix this.