Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Duck Duck Go has been eliminated but keeps coming back

  • 3 uphendule
  • 2 zinale nkinga
  • 126 views
  • Igcine ukuphendulwa ngu FredMcD

more options

When opening a new tab FF is opening Duck Duck Go after DDG has been removed. I have deleted and reinstalled FF several times, I have cleaned the cache.

I have set the homepage to https://startpage.com (SP,) I have removed the extension Duck Duck Go (DDG.) When starting FF it opens SP, but when I click on the new tab (+) it opens DDG. The trouble-shooting information below says that DDG is Enabled, but I have removed it and the extension is not listed in the Add-Ons manager.

I have set FF > Preferences > Home > ...New Windows and Tabs > Homepage and New Windows > Custom URLs... > https://startpage.com/ ...New Tabs > Firefox Home (Default)

Why is FF reverting to DDG? Where is DDG coming from? Can I stop/disable DDG from appearing?

Application Basics


Name: Firefox Version: 84.0 Build ID: 20201211215739 Distribution ID: canonical User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:84.0) Gecko/20100101 Firefox/84.0 OS: Linux 5.8.0-33-generic #36-Ubuntu SMP Wed Dec 9 09:14:40 UTC 2020 Multiprocess Windows: 1/1 Fission Windows: 0/1 Disabled by default Remote Processes: 10 Enterprise Policies: Inactive Google Location Service Key: Found Google Safebrowsing Key: Found Mozilla Location Service Key: Missing Safe Mode: false

Add-ons


... Name: DuckDuckGo Type: extension Version: 1.1 Enabled: true ID: ddg@search.mozilla.org ... Name: Startpage.com — Private Search Engine Type: extension Version: 1.3.0 Enabled: true ID: {20fc2e06-e3e4-4b2b-812b-ab431220cada}


Neofetch: OS: Ubuntu 20.10 x86_64 Host: N141CU Kernel: 5.8.0-33-generic Uptime: 7 mins Packages: 2313 (dpkg), 9 (snap) Shell: bash 5.0.17 Resolution: 2560x1440 DE: GNOME 3.38.1 WM: Mutter WM Theme: Yaru-dark Theme: Yaru-dark [GTK2/3] Icons: ubuntu-mono-dark [GTK2/3] Terminal: gnome-terminal CPU: Intel i7-10510U (8) @ 4.900GHz GPU: Intel UHD Graphics Memory: 3300MiB / 15700MiB

When opening a new tab FF is opening Duck Duck Go after DDG has been removed. I have deleted and reinstalled FF several times, I have cleaned the cache. I have set the homepage to https://startpage.com (SP,) I have removed the extension Duck Duck Go (DDG.) When starting FF it opens SP, but when I click on the new tab (+) it opens DDG. The trouble-shooting information below says that DDG is Enabled, but I have removed it and the extension is not listed in the Add-Ons manager. I have set FF > Preferences > Home > ...New Windows and Tabs > Homepage and New Windows > Custom URLs... > https://startpage.com/ ...New Tabs > Firefox Home (Default) Why is FF reverting to DDG? Where is DDG coming from? Can I stop/disable DDG from appearing? Application Basics ------------------ Name: Firefox Version: 84.0 Build ID: 20201211215739 Distribution ID: canonical User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:84.0) Gecko/20100101 Firefox/84.0 OS: Linux 5.8.0-33-generic #36-Ubuntu SMP Wed Dec 9 09:14:40 UTC 2020 Multiprocess Windows: 1/1 Fission Windows: 0/1 Disabled by default Remote Processes: 10 Enterprise Policies: Inactive Google Location Service Key: Found Google Safebrowsing Key: Found Mozilla Location Service Key: Missing Safe Mode: false Add-ons ------- ... Name: DuckDuckGo Type: extension Version: 1.1 Enabled: true ID: ddg@search.mozilla.org ... Name: Startpage.com — Private Search Engine Type: extension Version: 1.3.0 Enabled: true ID: {20fc2e06-e3e4-4b2b-812b-ab431220cada} ------------- Neofetch: OS: Ubuntu 20.10 x86_64 Host: N141CU Kernel: 5.8.0-33-generic Uptime: 7 mins Packages: 2313 (dpkg), 9 (snap) Shell: bash 5.0.17 Resolution: 2560x1440 DE: GNOME 3.38.1 WM: Mutter WM Theme: Yaru-dark Theme: Yaru-dark [GTK2/3] Icons: ubuntu-mono-dark [GTK2/3] Terminal: gnome-terminal CPU: Intel i7-10510U (8) @ 4.900GHz GPU: Intel UHD Graphics Memory: 3300MiB / 15700MiB

Isisombululo esikhethiwe

None of the search add-ons you cite exist on my system. However I have solved the problem by going to Startpage Settings > Enable Promotional Messaging and setting it On. Then restarting Startpage shows the button to make startpage my default engine. I have done so. Also, I Removed every add-on and rebooted the computer. Now DDG is no longer present.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (3)

more options

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; (<Control> [Mac=<Command>] <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Remove “ DuckDuckGo “ Anything.

Also remove SafeSearch, SearchAssist Incognito, FileConverter Addon, SearchLock, DiscreteSearch, WebSearch, Findwide Search Engine, securedsearch

Now do the same in the computer’s Programs Folder.

Windows: Start > Control Panel > Uninstall Programs. Mac: Open the Applications folder. Linux: Check your user manual.

more options

Isisombululo Esikhethiwe

None of the search add-ons you cite exist on my system. However I have solved the problem by going to Startpage Settings > Enable Promotional Messaging and setting it On. Then restarting Startpage shows the button to make startpage my default engine. I have done so. Also, I Removed every add-on and rebooted the computer. Now DDG is no longer present.

more options

That was very good work. Well Done.