Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Disable search in address bar function.

  • 5 uphendule
  • 1 inale nkinga
  • 1943 views
  • Igcine ukuphendulwa ngu Bells

more options

Even though I have deselected "Show search suggestions in address bar results" in my preferences, I can't get rid of it.

When I start typing in the address bar it has the whole drop down box with a bunch of search engines I don't want or use - YouTube, Facebook, Wikipedia, Reddit and Twitter.

It wasn't there before, and it's really annoying.

Isisombululo esikhethiwe

hello, the suggestions in the drop down are the first eight of your top site on the new tab page - you can edit or remove them there: https://support.mozilla.org/en-US/kb/customize-new-tab-page#w_customize-your-top-sites

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (5)

more options

I'm assuming you are talking about these? (See screenshot)

If so, and you only use a single search engine in Firefox, the easiest thing to do is to remove the rest of the search engines in the Firefox settings. That will hide those options from coming up because you will only have one search engine then.

If you go to the Firefox settings page and go to the Search section, you can remove the One-Click Search Engines by clicking on one and then pressing the Remove button. You'll want to keep whatever search engine you want Firefox to use though.

Hope this helps.

NOTE: Option 5 provided below by jscher2000 is a better solution.

Okulungisiwe ngu Wesley Branton

more options

There are three interrelated functions:

(A) Submit the contents of the address bar to your default search engine if it isn't a valid URL (for example, if it's the word Firefox or a phrase with spaces)

(B) Show suggested matches from your default search engine on the drop-down along with other suggestions -- you've turned this one off on the Options page

(C) Show a bar of "one-time" search buttons along the bottom of the drop-down

If you don't want (A) or (C), you can switch a preference in the Advanced Preferences editor (Configuration Editor for Firefox). Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

To get rid of (A):

(2) In the search box in the page, type or paste keyw and pause while the list is filtered

(3) Double-click the keyword.enabled preference to switch the value from true to false -- invalid addresses should return a server not found error (single words will be tried with www.what-you-typed.com unless you also turn off browser.fixup.alternate.enabled)

To get rid of (C):

(4) In the search box in the page, type or paste URLB and pause while the list is filtered

(5) Double-click the browser.urlbar.oneOffSearches preference to switch the value from true to false -- the bar should no longer appear on the drop-down

more options

Still can't get rid of it!

This is what is happening

75.0 on Mac if that helps :)

Okulungisiwe ngu Bells

more options

Isisombululo Esikhethiwe

hello, the suggestions in the drop down are the first eight of your top site on the new tab page - you can edit or remove them there: https://support.mozilla.org/en-US/kb/customize-new-tab-page#w_customize-your-top-sites

more options

Thanks @phillipp, that did the trick.

I also went to the Privacy and Security section of preferences and unticked all the boxes under 'Address Bar". I hadn't looked there, only in the Search section.