X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Every time I try to make or receive a call it asks for permission to use the microphone in GMAIL Hangouts.

Kuphostiwe

Every time I try to make or receive a call it asks for permission to use microphone in Gmail Hangouts https://mail.google.com/mail/u/0/#inbox . I have it set to "Allow". https://mail.google.com/mail/u/0/#inbox When a call comes in or I try to make one it does not have the check mark box "Always Allow" on the little pop up window as I have seen before. I can set it to always allow by right clicking the chat window and page info, yet it keeps on asking for permission to use. -- It DOES show as being allowed both in the list in Options and when you check the page Info.

I thought maybe it has something to do with Flash ending, but when I use Hangouts on the Hangouts page: https://hangouts.google.com/ it works fine. And yes, I have removed all cookies and cache several times. Another thing I noticed is that you can't add any pages manually in the options. Not sure if that is related. Note that I use Firefox and Windows 7 .

Been searching for an answer since this started over a month ago. Thank you in advance for your help.

Every time I try to make or receive a call it asks for permission to use microphone in Gmail Hangouts https://mail.google.com/mail/u/0/#inbox . I have it set to "Allow". https://mail.google.com/mail/u/0/#inbox When a call comes in or I try to make one it does not have the check mark box "Always Allow" on the little pop up window as I have seen before. I can set it to always allow by right clicking the chat window and page info, yet it keeps on asking for permission to use. -- It DOES show as being allowed both in the list in Options and when you check the page Info. I thought maybe it has something to do with Flash ending, but when I use Hangouts on the Hangouts page: https://hangouts.google.com/ it works fine. And yes, I have removed all cookies and cache several times. Another thing I noticed is that you can't add any pages manually in the options. Not sure if that is related. Note that I use Firefox and Windows 7 . Been searching for an answer since this started over a month ago. Thank you in advance for your help.
Ama-screenshot ananyekiwe
Isicaphuno

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 32.0 r0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

Eminye Imininingwane

jscher2000
  • Top 10 Contributor
8698 izisombululo 71098 izimpendulo
Kuphostiwe

I wonder whether this is because Hangouts is in a frame in the Gmail page? In other words, maybe Firefox feels the need to get explicit confirmation because the URL bar host name and the frame host name are different, as shown in your fourth screenshot:

Even though both hosts are allowed. If that's the issue, I don't know whether there is an additional setting available now to work around that, or whether the developers would need to add a new one.

I wonder whether this is because Hangouts is in a frame in the Gmail page? In other words, maybe Firefox feels the need to get explicit confirmation because the URL bar host name and the frame host name are different, as shown in your fourth screenshot: <img src="https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2019-09-21-11-42-02-35ef4d.png"> Even though both hosts are allowed. If that's the issue, I don't know whether there is an additional setting available now to work around that, or whether the developers would need to add a new one.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17481 izisombululo 157975 izimpendulo
Kuphostiwe

Are you possibly using Private Browsing mode (Never Remember History) ?

Are you possibly using Private Browsing mode (Never Remember History) ?
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

jscher2000 said

I wonder whether this is because Hangouts is in a frame in the Gmail page? In other words, maybe Firefox feels the need to get explicit confirmation because the URL bar host name and the frame host name are different, as shown in your fourth screenshot: Even though both hosts are allowed. If that's the issue, I don't know whether there is an additional setting available now to work around that, or whether the developers would need to add a new one.

That's a very good observation, and it may have something to do with it. However it has always worked fine for 2.5 years, and hangouts.google.com has the permission given to Always Allow. But maybe with the updates they changed it like you say because of the frames. Note the little check box that is missing in pop up is "Remember this decision", not Always Allow as I stated.

''jscher2000 [[#answer-1253970|said]]'' <blockquote> I wonder whether this is because Hangouts is in a frame in the Gmail page? In other words, maybe Firefox feels the need to get explicit confirmation because the URL bar host name and the frame host name are different, as shown in your fourth screenshot: <img src="https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2019-09-21-11-42-02-35ef4d.png"> Even though both hosts are allowed. If that's the issue, I don't know whether there is an additional setting available now to work around that, or whether the developers would need to add a new one. </blockquote> That's a very good observation, and it may have something to do with it. However it has always worked fine for 2.5 years, and hangouts.google.com has the permission given to Always Allow. But maybe with the updates they changed it like you say because of the frames. Note the little check box that is missing in pop up is "Remember this decision", not Always Allow as I stated.
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

cor-el said

Are you possibly using Private Browsing mode (Never Remember History) ?

I never use Private Browsing.

''cor-el [[#answer-1253974|said]]'' <blockquote> Are you possibly using Private Browsing mode (Never Remember History) ? </blockquote> I never use Private Browsing.
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

Anybody else have any ideas how to solve please?

Anybody else have any ideas how to solve please?
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

Please???

Please???
Ingabe lokhu kube usizo kuwena?
Isicaphuno
jscher2000
  • Top 10 Contributor
8698 izisombululo 71098 izimpendulo
Kuphostiwe

I don't see a setting that would treat permissions differently in a frame.

Do you want to set the default microphone permission to Allow to see whether that makes any difference? Of course, this isn't the setting you'll want to use while randomly roaming the web...

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste microp and pause while the list is filtered

(3) Double-click the permissions.default.microphone preference to display a dialog where you can enter the desired value, make the edit, then click OK:

  • 0 = Prompt for permission, unless there's an exception
  • 1 = Allow automatically (try this temporarily)
  • 2 = Block permission requests

If Firefox still doesn't allow the framed usage seamlessly, then there definitely must be something special about the way frames are handled. You could file a new bug about it: https://bugzilla.mozilla.org/

I don't see a setting that would treat permissions differently in a frame. Do you want to set the default microphone permission to Allow to see whether that makes any difference? Of course, this isn't the setting you'll want to use while randomly roaming the web... (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''microp''' and pause while the list is filtered (3) Double-click the '''permissions.default.microphone''' preference to display a dialog where you can enter the desired value, make the edit, then click OK: * 0 = Prompt for permission, unless there's an exception * 1 = Allow automatically '''(try this temporarily)''' * 2 = Block permission requests If Firefox ''still'' doesn't allow the framed usage seamlessly, then there definitely must be something special about the way frames are handled. You could file a new bug about it: https://bugzilla.mozilla.org/
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

Thank you for trying to help. I just tried what you suggested and it does the exact same issue with asking for the permission. What's so frustrating is that it has not had this problem for years then suddenly (probably from a Firefox update) it started. I will go ahead and do the bug report.

Thank you for trying to help. I just tried what you suggested and it does the exact same issue with asking for the permission. What's so frustrating is that it has not had this problem for years then suddenly (probably from a Firefox update) it started. I will go ahead and do the bug report.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.