Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Camera is not working in FF until I give permission in Safari

  • 20 uphendule
  • 1 inale nkinga
  • 93 views
  • Igcine ukuphendulwa ngu firefox1210

more options

Hi all,

my Camera is not working in Firefox on https://www.onlinemictest.com/webcam-test/ even though it does work on this site in Safari or Chrome. And before the question comes. Yes I taped on the play button, and yes I allowed the website to access my camera. Still the rectangle that would show my face now stays black.

And here comes the weird part. If I start Safari at the same time on the same website. And if I then tap on play and give the permission. It works instantly on FF and Safari?

I'm unsing FF Quantum 68.0.2 on a MacBook 12" with Mac OS - Mojave (10.14.6)

Any ideas?

All Replies (20)

more options

And here are some additional pictures showing the problem.

more options

Hi firefox1210,

Have you tried starting Firefox in Safe Mode to see if the problem continues there?

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.

Let's take a look at your about:config page to see if anything there has been modified.

1.) Type about:config into a new tab's address bar. Hit enter and click the button accepting the risk.

2.) Type media*enable into the search bar at the top and wait for the results list to populate.

3.) Look for any results in the list that are bolded. If something is in bold it has been modified and could be preventing your camera from working.

more options

Hi Brady,

actually yes, I tried the safe mode before and it did not make any difference. I tried it once again 5 minutes ago. Still the same behaviour.

In the about:config when I filter for "media*enable" nothing is bold. :(

more options

Hmm. Have you changed your default browser to be Firefox? I believe you said you have already done this, but I would double check that Firefox has permission to use your camera both in your system preferences and the browser itself.

Let me look into this a little further or see if we can get some extra help.

more options

Ballison said

Hmm. Have you changed your default browser to be Firefox? I believe you said you have already done this, but I would double check that Firefox has permission to use your camera both in your system preferences and the browser itself.

Now the Browser is my default browser. I also rebooted the Mac. But the behaviour stays the same.

more options

Today I tried Firefox Nightly 70.0a1 (2019-08-27) (64-Bit) . No difference. The rectangle that would show my face stays black after givin the permission.

And then I jumped back to Firefox 56.0 and it was working as it is supposed to to work.

I have no clue. Any ideas out there?

more options

Hello firefox1210,

Just a stab in the dark, but none of your screenshots show that you have given the site permission (I don't see a little dot on the edge of the little "i" in a circle).

Would you try this please :

When you're on a site where you need to use the camera, click on the 'i' in a circle, next to the padlock at the left side of the address bar.

Then click on the little black arrow on the dropdown (next to 'Connection') and then on "More Information", which will take you to "Page Info".

Click on the 'Permissions" tab and scroll down to "Use the Camera". Uncheck "Use Default" and check "Allow".

Then close and restart Firefox.

Any luck ?

more options

McCoy said

Click on the 'Permissions" tab and scroll down to "Use the Camera". Uncheck "Use Default" and check "Allow". Then close and restart Firefox. Any luck ?

Hey Mcoy it did unfortunatelly not change the behaviour :/

more options

After your last (disappointing) post, I decided to try it myself.

Did the test ........ didn't work for me either.

So I decided that it must be something in my system's settings - I am not on Mac though, but on Windows.

Checked the settings for the camera in Windows Settings : had to turn them on - did the test again and ...... yay  !

I was going to suggest that you'd do the same on your system, but then I remembered you saying :

"If I start Safari at the same time on the same website. And if I then tap on play and give the permission. It works instantly on FF and Safari? "

That is sooo weird (to me, anyway).

But still : it's worth a try though ...... (unless you already have).

more options

McCoy said

But still : it's worth a try though ...... (unless you already have).

I did ;)

I'm trying every possibility for 3 weeks now. I hope that someone comes up with a new idea. I'm looking forward for every suggestion.

more options

firefox1210 said

I'm trying every possibility for 3 weeks now. I hope that someone comes up with a new idea. I'm looking forward for every suggestion.

That must be sooo frustrating .....

If I'm not mistaken : I think that fellow contributor Ballison has already forwarded this to someone who might know what's going on here - problem is : I haven't seen that "someone" around ......

I will see if I can reach someone - please hang in there.

more options

'Just forwarded this thread to another contributor, who might not be "around" for hours (we're dealing with different time zones).

I couldn't let this go just yet and I did some searching about how this works on your system (must admit that most of it is mumbo-jumbo to me), but when I read this article I was wondering :

Could it be that maybe you need to enter Firefox as app that you want to allow access to your system's camera ?

(edit : typo)

Okulungisiwe ngu McCoy

more options

You can check in the Mac System Preferences to see if you currently have allowed or blocked Firefox like written in the above posted link.

  • Apple menu -> System Preferences -> Security & Privacy -> Privacy tab at the top
more options

McCoy said

Could it be that maybe you need to enter Firefox as app that you want to allow access to your system's camera ? (edit : typo)

Yes I gave this permission when I installed Safari. But I verified it and the permission is still there.

more options

cor-el said

  • Apple menu -> System Preferences -> Security & Privacy -> Privacy tab at the top

Thank you for showing the way. The permission is given.

more options

firefox1210 said

The permission is given.

I wanted to say that it was already given before. The problem still exists.

more options

This keeps bothering me .....

Do you by any chance use the ManyCam on your system ?

Here's why I'm asking :

https://help.manycam.com/knowledge-base/manycam-virtual-webcam-is-not-detected-in-firefox-for-macos/

more options

McCoy said

Do you by any chance use the ManyCam on your system ?

Thank you for the question, but no I'm not using ManyCam.

more options

I am coming from Windows 10 side here. I do know unless you tell or configure the WebCam settings in Windows 10 other applications will not be able to use it and I can guess iOS uses this same principle as well for security and privacy purpose. I know this because a Mic setting in Windows 10 if you turn it off or disable no other apps can see or use it.

more options

WestEnd said

I do know unless you tell or configure the WebCam settings in Windows 10 other applications will not be able to use it and I can guess iOS uses this same principle as well for security and privacy purpose.

If I understand you correctly. Yes the permissions are given and the settings are made.