X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Disable search possibility in URL bar

Kuphostiwe

Hello ! I'd like to disable the possibility to search with my search engine on firefox in the URL bar and be able only to search with the search bar. I'd like to make the url bar says an error if I type something isn't an URL. I've got Firefox 67.0.2 (latest version for the moment)

Hello ! I'd like to disable the possibility to search with my search engine on firefox in the URL bar and be able only to search with the search bar. I'd like to make the url bar says an error if I type something isn't an URL. I've got Firefox 67.0.2 (latest version for the moment)

Isisombululo esikhethiwe

Hello By_JumperX4,

Would you try this please :

Type in the address bar about:config and press Enter (promise to be careful, if asked)

Type in the search bar keyword.enabled

And set its value to false

Do the same with browser.fixup.alternate.enabled

and browser.urlbar.suggest.searches

Then close and restart Firefox.


In Options => Search, uncheck :

"Show search suggestions in address bar results" and : "Show search suggestions ahead of browsing history in address bar results"

Funda le mpendulo ngokuhambisana nalesi sihloko 1
Isicaphuno

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 32.0 r0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

Eminye Imininingwane

McCoy
  • Top 10 Contributor
520 izisombululo 4892 izimpendulo
Kuphostiwe

Isisombululo Esikhethiwe

Hello By_JumperX4,

Would you try this please :

Type in the address bar about:config and press Enter (promise to be careful, if asked)

Type in the search bar keyword.enabled

And set its value to false

Do the same with browser.fixup.alternate.enabled

and browser.urlbar.suggest.searches

Then close and restart Firefox.


In Options => Search, uncheck :

"Show search suggestions in address bar results" and : "Show search suggestions ahead of browsing history in address bar results"

Hello By_JumperX4, Would you try this please : Type in the address bar '''about:config''' and press Enter (promise to be careful, if asked) Type in the search bar '''keyword.enabled''' And set its value to '''false''' Do the same with '''browser.fixup.alternate.enabled''' and '''browser.urlbar.suggest.searches''' Then close and restart Firefox. ------------------------------------------------------------------------------------------- In Options => Search, uncheck : "Show search suggestions in address bar results" and : "Show search suggestions ahead of browsing history in address bar results"
Ingabe lokhu kube usizo kuwena? 1
Isicaphuno

Umnikazi wombuzo

Thank you !!! It works ! If you have any way to remove the small search icon in the URL bar when there is nothing inside it will be perfect !

Thank you !!! It works ! If you have any way to remove the small search icon in the URL bar when there is nothing inside it will be perfect !
Ingabe lokhu kube usizo kuwena?
Isicaphuno
McCoy
  • Top 10 Contributor
520 izisombululo 4892 izimpendulo
Kuphostiwe

Impendulo Ewusizo

By_JumperX4 said

Thank you !!! It works ! If you have any way to remove the small search icon in the URL bar when there is nothing inside it will be perfect !

I'm glad it worked - well done  !

You mention a "small search icon": I assume you're talking about a magnifying glass  ?

You would need to add code to the userChrome.css file :

https://www.reddit.com/r/FirefoxCSS/comments/9jui4b/remove_magnifying_glass_icon_from_address_bar/

''By_JumperX4 [[#answer-1230418|said]]'' <blockquote> Thank you !!! It works ! If you have any way to remove the small search icon in the URL bar when there is nothing inside it will be perfect ! </blockquote> I'm glad it worked - well done ! You mention a "small search icon": I assume you're talking about a magnifying glass ? You would need to add code to the userChrome.css file : https://www.reddit.com/r/FirefoxCSS/comments/9jui4b/remove_magnifying_glass_icon_from_address_bar/
Ingabe lokhu kube usizo kuwena? 1
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17415 izisombululo 157316 izimpendulo
Kuphostiwe

Other possible code for userChrome.css :

#urlbar[pageproxystate="invalid"] > #identity-box > #identity-icon {
 fill-opacity:0 !important;
}

Other possible code for userChrome.css : <pre><nowiki>#urlbar[pageproxystate="invalid"] > #identity-box > #identity-icon { fill-opacity:0 !important; }</nowiki></pre> ---- *https://www.userchrome.org/what-is-userchrome-css.html *https://www.userchrome.org/how-create-userchrome-css.html
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

McCoy said

Hello By_JumperX4, Would you try this please : Type in the address bar about:config and press Enter (promise to be careful, if asked) Type in the search bar keyword.enabled And set its value to false Do the same with browser.fixup.alternate.enabled and browser.urlbar.suggest.searches Then close and restart Firefox.

In Options => Search, uncheck :

"Show search suggestions in address bar results" and : "Show search suggestions ahead of browsing history in address bar results"

''McCoy [[#answer-1230409|said]]'' <blockquote> Hello By_JumperX4, Would you try this please : Type in the address bar '''about:config''' and press Enter (promise to be careful, if asked) Type in the search bar '''keyword.enabled''' And set its value to '''false''' Do the same with '''browser.fixup.alternate.enabled''' and '''browser.urlbar.suggest.searches''' Then close and restart Firefox. ------------------------------------------------------------------------------------------- In Options => Search, uncheck : "Show search suggestions in address bar results" and : "Show search suggestions ahead of browsing history in address bar results" </blockquote>
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.