Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

default profile only works when run with --profile

  • 3 uphendule
  • 1 inale nkinga
  • 35 views
  • Igcine ukuphendulwa ngu cor-el

more options

After a crash, I'm having a strange problem where firefox (nightly 69.0a1+20190604+hdfc513e7e141 , Arch Linux AUR package, under GNOME Wayland) only actually loads/renders web pages if run with the command-line switch

`--profile ~/.mozila/firefox/xxxxxxxx`

where `xxxxxxxx` is the path to the default profile. If I omit the command-line switch, firefox seems to run fine except that no connections are ever successfully made and all pages remain blanck.

I imagine there is a corrupted file somewhere but i don't understand why the default profile would work fine when it is explicitly invoked with the `--profile` switch, but not otherwise.

Thank yo uas always!

Isisombululo esikhethiwe

See also:

  • Bug 1543600 - [Wayland] Enable by default on nighly & qualified systems
  • Bug 1522780 - [Wayland] Use MOZ_ENABLE_WAYLAND to enable wayland backend
Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (3)

more options

Just checked with a local file, and it appears that local resources load but all non-local resources are blocked -- they don't even appear in the network pane of the devtools. THank you for hte help!

more options

When you start Nightly without a profile path, what profile does it use? Try loading the internal about:profiles page to see its name and path. There also is a possibility that it creates and uses a temporary profile. And/or that it's a new Nightly glitch that support forum volunteers won't know anything about.

more options

Isisombululo Esikhethiwe

See also:

  • Bug 1543600 - [Wayland] Enable by default on nighly & qualified systems
  • Bug 1522780 - [Wayland] Use MOZ_ENABLE_WAYLAND to enable wayland backend